Tables in task description

It would be great to add tables in the description of a task, comes in handy quite often.

Hi @CreativeNorthMedia , this has been recently added and now possible from the + button within the description editor


Awesome, which version? I’m currently on 1.13.0 and its not there.

Screenshot 2023-04-15 at 10.29.39 AM
Screenshot 2023-04-15 at 10.29.48 AM

Screenshot 2023-04-15 at 10.31.30 AM

Your screenshots appear to be from the task comments, not the task description.

Ah yes indeed, long day!

I have the same menu items in Description, no tables available

Oh it seems like it was fully rolled out yesterday!

Try to reload and see if it works now…?


I can’t tell you how happy I am for this addition!

I have a few issues/feedback/questions (perhaps you are working on it):

  1. On the app, the table appears which you need to click on. Will this be viewable in the future without the need to click?
  2. If there is an image in the table, on the app, the content isn’t appearing at all, it’s blank.
  3. On the desktop version, when I click “print” the project the images are not appearing if in a table.

Thanks in advance! You guys are awesome. Love this update, hoping it will continue to evolve!

Sorry I meant “print” the task, not the project

Hi @shyrah , glad you are enjoying these updates. :smiley:

Just to clarify, I don’t work for Asana, therefore I have no insight into Asana’s roadmap (which they do not make public anyway).

I’m actually a Solutions Partner and, like other partners in the forum, we provide consulting services to help teams to get the most out of Asana by designing and setting up workflows to get them up and running with ease, amongst other services :wink:

Regarding your issues:

  1. I believe this is expected current behaviour on the mobile app
  2. That’s strange because I just tried it and the image shows up fine on both desktop and mobile app
  3. Similarly, the image also shows up when I print the task

It could be that your image type is not in a supported format. Also, if you are copy/pasting an image from another table, try pasting just the image itself into a cell of your table in Asana.

1 Like

Brilliant! Much better now.


Thank you Richard!

1 Like

Could you please specify what version I should utilize to use tables? Currently, it’s 1.15 and there’s nothing about this feature.
Thank you