Sub Task Due Dates in Calendar and List?

subtasks
due-dates
tasks
calendar
listview

#1

Here is how I use Asana and now have run into a problem: I create Sections on my List View that are print ad companies. I then make my Tasks which are each print ad. In the Task are Sub-Tasks: ‘Create’ & ‘Submit’. Both of those have separate due-dates. The main task does not have a due date, because I rely on the sub task due dates. When I try to sort my list by due date none of my sub tasks show up. My calendar does not show my sub-task due dates either. How can I see when anything is due? Does Asana really expect me to make individual tasks for creating an ad and submitting an ad? Sub-tasks are then pointless? This is hindering my work flow. Anyone have any suggestions?


#2

Hi @Hollie_Goss, yes this is an unfortunate limitation of Asana right now and I can see a lot of people are asking the same thing. For now, one workaround is to add the subtask back to the main project. By doing this, the subtask will show on the calendar. Sorry, I don’t have a better solution.

Alternatively, you could use a section for each print ad (with no due date) and the subtasks become normal tasks. You could then use a tag to display the print ad company.,

Hope this helps!


#3

Hitting the same wall.


#4

Thank you for the response. Unfortunately, that is more clutter and work for us regardless of which method we use.


#5

Hi @Hollie_Goss & @Jen_Manning; Michael from Asana here.

@paulminors is right on the money here. At the moment due to the way our data model is structured, you need to manually add the Project to your subtasks. You can do so in bulk (by multi-selecting the subtasks in the parent task, and using theTab+P hotkeys, then the Tab button to add them to the Project they should be a part of. Once you’ve added them to do the Project, adding a due date will ensure that they show up in calendar view.

Wish we had a better answer to this (know we’re working on it!), though this workaround will have your Subtasks acting as you want them to.

Hope this helps!


#6

@Michael_A I didn’t realise the Tab + P shortcut worked on subtasks when you bulk select. I tried this but couldn’t get it to work…


#7

Hi, This is killing us too - 60 users in our org with this as a major blocker for proper implementation.

any update?