Status Update edits are not reflected when exporting Portfolio to CSV

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When editing an existing status update in the Progress tab of a projects, these edits are not reported in the portfolio csv export. Original version (before edits) gets reported instead.

Steps to reproduce:
To edit a status update:

  1. Go to Progress tab
  2. Next to the status update, click on … then 'Edit status update
  3. Make edits, then click on Save Changes

To report the portfolio status:

  1. Go on the portfolio Projects tab
  2. Click on the arrow next to the portfolio name, then Export and then CSV
  3. Save the CSV file

Browser version:
Google Chrome Version 85.0.4183.121 (Official Build) (64-bit)

Upload screenshots below:
n/a

Hi @Pasquale_Guaglianone, welcome to the Asana Community Forum!

I followed the steps but I wasn’t able to reproduce the issue on my end. I see the last status update in the “LATEST STATUS UPDATE” column when I open the CSV file in Numbers in Mac.

In order to investigate this further, could you please confirm this information:

  • Are you experiencing this issue with a specific project in your Portfolio or all projects?
  • Have you tried to export your portfolio from a incognito window and the issue persist?
  • Just to confirm, is the status you are expecting to see in your CSV the one you post in your Project or in your Portfolio?

Looking forward to your reply!

Hi @Emily_Roman,

I am experiencing this issue at portfolio level, my expectation is to see in the CSV the updates posted in each project Progress tab.

If it helps to reproduce the issue:
a) if I post the update and do not edit it anymore, the export works correctly and “LATEST STATUS UPDATE” column includes the latest update
b) if I post an update and then edit it, the export works incorrectly and “LATEST STATUS UPDATE” column includes the original update (without the edits)

Unfortunately I cannot test on a incognito window, I access Asana through corporate SSO and that does not work on incognito window.

Thank you!

Thanks for confirming this information @Pasquale_Guaglianone! I was able to reproduce this issue when updating the name of the project status sections. When I export the Portfolio status, the sections are not updated.

I’ve gone ahead and escalated this bug to our development team. I’ll get back to you as soon as I have an update.

Thanks again for your report and please let me know if you have any questions in the meantime!

Hi @Emily_Roman is there any update on this bug? When can we expect it to be fixed?

Thanks!

Hi @Pasquale_Guaglianone, unfortunately I don’t have a exact date but I see this bug has been prioritized and our team will work on it soon. I’ll let you know as soon as I have more details.