Slack integration in custom rules breaks daily

I love the idea of the new Slack integration tying in with custom rules, but this feature breaks every other day for us.

As an agency, we have several Asana boards related to a client (depending on the team), but only one Slack channel for that client (for cross-disciplinary communication). I went through and added a rule that posts to to the client’s Slack channel whenever a comment is posted on a task as
sometimes input is needed across teams, and I want to improve visibility.

Right after setting up the integration on multiple boards, and for a day or so, the rules post messages just fine. Small delay, but still gets posted. However, I notice that after about 36-48 hours, these rules break, and I need to re-authorize Slack. Once I do that, again it works for a day or so, and then breaks.

I don’t know if I am doing something wrong, or something is misconfigured in our Slack admin. I am an admin of both, if it helps.

Any assistance would be appreciated!

4 Likes

Hi @Bryan_Wojciechowski, thanks for reaching out and sorry for the trouble here! In order to best assist you, could you confirm the following information please?

  • Are you getting a disconnected error message within the integration? It would be also very helpful if yo could send us a screenshot.
  • Are other users in your Organization also experiencing the error you mentioned

Looking forward to your reply!

@Emily_Roman Our experience has been exactly as described above. Worked fine at setup. Now we are getting the same breakage described by Bryan. This is creating some P0 issues for us. We want to use our slack integration to kick alerts for urgent matters to our legal team. Every time the Slack alert is triggered, though, it breaks the integration before sending the slack alert.

Hi Emily,
Here is a screenshot, it’s not much info to go off of.
image

The rule breaks at the integration level, so once it breaks, it is broken for everyone.

Thanks for your report and confirming this information, @Bryan_Wojciechowski and @erik1! I’ve gone ahead and escalated this to our product team so they can investigate further. I’ll let you know as soon as I have an update!

I’m having the exact same problem, I submitted via the Feedback link as well. It breaks every single day and asks to re-authenticate.

Screen Shot 2021-02-20 at 12.00.36 PM

Thanks for your report, @Steve_Patrizi! Our team is working to resolve this issue and we hope to have an update soon. I’ll keep you posted.

Ditto, I’m experiencing this issue as well.

Thanks for reaching out @Matt33 and sorry for the trouble! We are currently. investigating this issue, I will update this thread as soon as I have an update!

I am having the exact same issue. Every day I have to check to see if a rule is broken due to an Authentication issue with Slack 🤦

Is it wrong that I find comfort in seeing others having the same problem? Now at least I know I am not crazy and doing something wrong on my end.

1 Like

Same here! It breaks every single day to the point where you can not even use it.

Yeah, I’m seeing the same issue as well. Authentication breaks every few hours.

This is very unfortunate. If the integration would work properly then it solves some shortcomings that the rules feature has had.

Just checking in on the remediation for this issue? I have one project I use (4) Slack notification rules as rule actions. After some research I noticed a pattern where any given rule “breaks” daily (By breaks, I mean at least one of the Slack plug-in action/rules needs to be re-authenticated) and begins working again, so the upside is that it forces me to monitor this particular Project on a daily basis to make sure the emergency alerts are working…

UPDATE: I can’t even get into the rules now, clicking on it causes an Asana crash in the same browser I’ve been using for over a year (Edge on Mac). I feel like maybe an alert triggering is what is breaking the rule, perhaps? Not sure, just trying to offer some specific data to help advance the issue.

image

@Ralph_Carlone Same issue for me. This is even worse now. Hopefully, this is a sign that Asana coders are working behind the scenes right now fixing the issue :crossed_fingers:

Having the same issue, it breaks every couple of hours, which makes the feature completely worthless.

Thanks for your reports and so sorry for the inconvenience here! Our team is currently working on a fix for this issue and we hope to have a solution soon!

@Emily_Roman - Thank you for the update, much appreciated!

This is happening to us, also - the integration breaks constantly

Hi everyone! This issue should be solved now! :tada: If you still experience you will need to re-authenticate 1 more time but that should not be required going forward.

1 Like