Server Error on Android App

I am on Android 8.1, I am unable to log in via the app. I keep on getting a server error. Login via google or with my username and password does the samething.

Hi @Kelvin_F_Alfaro. Have you tried re-installing the app? If the issue persists, let me know! :slight_smile:

Yes I have. I completely uninstalled and reinstalled, issue persists.

Thanks for getting back to me @Kelvin_F_Alfaro and so sorry for the trouble. Could you please send me a screenshot of the error message you’re getting in order for me to investigate this issue further?

1 Like

Not much of an error

Hi, Even with the few redesigned login on the Android app, I am still unable to login.

Marie, any update on this.

Hi @Kelvin_F_Alfaro and apologies for the late follow-up! Are you having the same issue when trying to log in via from a computer? I’m just wondering if the issue is definitely related to the app or if it is password-related. I look forward to your reply! :slight_smile:

hi @Marie this only happens on my mobile android phone. My computer access is fine. Also loading the desktop view on chrome on my android phone works fine. It is strictly contained to the app.

Hi @Marie, I am not sure how to share other information to give you a sense of the error. I am still unable to use the Android app. Can you help?

Thanks for following-up @Kelvin_F_Alfaro. This indicates the issue is directly related to the application. I would just need one last thing; could you please confirm which version of Android and version of the Asana app you’re using so I can escalate this issue to our Development Team? I look forward to your reply!

I am also have the same issue on Android 8.1 and 9.0

Same is happening to me since update. Please fix as I’m now chained to my laptop :pray:

Hi @Jordan_Glasner and sorry you’re running into trouble here.

Have you tried to re-install your app?

Could you also confirm what version of Android and what version of the Asana app you’re using?

Looking forward to your reply!

Android 9. Asana is the latest from Play Store. Have uninstalled and cleared all cached data to no avail

Thanks for the quick follow-up @Jordan_Glasner;

One more question, could you send a screenshot of the error message you’re getting?

It’s no longer showing an error message. The flow is:

  • login with email (no password)

  • get redirected to web view

  • login to okta

  • get redirected back to splash screen

Seems the Android app doesn’t realize it’s receiving an oauth callback

Thanks for the additional information @Jordan_Glasner.

Sounds like the issue you’re encountering is directly linked to your SAML set up, so I would recommend reaching out directly to our support team who will be able to take a direct link into your account and escalate the issue to our development team if necessary.

In order to avoid having to re-explain the issue you’re encountering to our support team, feel free to share this link in your email to support (Server Error on Android App - #17 by Jordan_Glasner) so they have all context necessary to help you out! :slight_smile:

I think this error could be browser problem of your phone. You may change your browser by using content:// syntax. Probably your problem be solved.