Screen recording with Vimeo on Safari not working

Using Safari browser to record videos and screen recordings…I am able to successfully record a video. When I try to do screen recording, I get a request from Safari to “allow” screen sharing, I confirm, the recording dialogue box comes up, but the screen recording never begins. Is there a setting that I need to adjust? Same is true for Camera+ screen recording. Thanks for any assistance you can offer.

Hello @Chris_Harris2

I just tested this on Safari and by selecting “Allow” for every Privacy request I received, it worked out.

Some options I could think of:


Check out the Safari settings by hitting “⌘ + ,” to enter the settings and allow Asana for Camera, Microphone and Screen Recording.


Ensure MacOS and Safari are updated to the latest version available for your machine.


Restart your machine :slight_smile:

This should do, let us know if none of that works though!


Hi Rosario,

Thanks for your reply.

My Safari settings for Camera and Microphone are set to “Allow” for Asana
My Safari setting for Screen Sharing only has two options for Asana….”ask” or “Deny” and it’s set to ask/

My iMac is running the latest versions of Safari and MacOS

I restated my iMac

Again, if I am doing just a video recording, the audio and video work fine, the recording buttons all work, and the video loads into my comment or description field as desire.

If I try to do Screen Recording, or Screen & Camera, I get a prompt asking me to “allow” Asana to share my screen, and I accept that option.

I get the 3,2,1 countdown, the video screen appears, and the controls box (with play, pause, delete icons) appears. However, at the end of the countdown nothing happens….the seconds on the control box doesn’t show elapsed time. And essentially my Safari screen is frozen. I have to quite Safari to get out of it.

I tried this in Safari on my iPad and didn’t get any further there either.

In studying the Vimeo help logs, they talk a lot about the Vimeo extension for Chrome. I’ve tried to see if there is a Vimeo extension for Safari but I’m not finding anything.

I’m interested that it’s working for you but not me. Happy to zoom with you and share my screen so you can see my experience, and perhaps troubleshoot a bit more. I’m feeling like there some slight fix I need to do, so close, but just can’t find it.

I’d love to be able to use this feature!! I’m often working nights and weekends and could send along a rich comment to colleagues and they can watch at their convenience.

Thanks for your help!


Hi @Marie,

We’ve been testing this with @Chris_Harris2, and I am concluding that this might be a bug.

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Vimeo screen recording will not work on Safari. After clicking “Start recording” the pop-up that is supposed to allow the user to choose the screen or window to record does not show up.

Steps to reproduce:
Start a Screen recording on Safari.

Note this might be a tricky one to reproduce. On my machine, with the same MacOS and Safari versions, I am unable to reproduce it.

  • Safari cache and files were cleaned.
  • The system was restarted.

Browser version:
Safari - 16.0 (17614., 17614)
MacOS - 12.6

:bulb: Note Vimeo recording works on his machine in Chrome as expected.

Upload screenshots below:
See the posts above by Chris.

Thank you,

Thanks for flagging this, @Chris_Harris2 and thanks for helping out with troubleshooting, @Rosario_Messina!

I’ve flagged this with the Product team and will let you know when I receive any updates :slight_smile:

1 Like

Any updates on this matter? Seem to be having the same issue on my end with Safari/Chrome.

1 Like

Nothing back to me from Asana so far

Thank you for the response @Chris_Harris2 - I am getting an error in f12 Dev tools. It should help development diagnose the issue. The issue I am having is in Chrome and Safari and since Chrome is a recommended browser they should be able to figure it out with this error code.

@Rosario_Messina / @Rebecca_McGrath - Can you see if this will help → Thank you.

Hey, Asana, is there any update on this issue?

Still hoping for an update on this issue, see data from Edward Micciulli above. It’s been 4 months and nary a peep from Asana!

Any update on this. Pretty dissapointing not to be able to use this feature.

Hi everyone, sorry for the delay. Because we are not able to replicate this issue on our end, this is requiring a bit of investigation. Our team has been doing some work on the Vimeo integration and some of the issues reported by users have been fixed. Can you confirm if you are still running into this permission issue?

For Safari users, can you please follow these steps and let us know if the problem persists?

Go to System Preference → Security & Privacy → Privacy tab → select ‘Screen Recording’ from the list on the left, and make sure Safari is on the list. If not, use the ‘+’ to add it, and grant permission.

We appreciate your help!

Vanessa, I’m happy to report that solution for Safari works. I will play with it over the next few days and report any wrinkles I run into.

Thanks for confirming, @Chris_Harris2. Glad to hear that this worked! :slight_smile:

Hi @Edward_Micciulli, our developers believe that this issue has since been resolved. Can you confirm if you are still seeing the error messages on your end? Thank you!

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.