Remove Google Drive Field

I tried using the #google-drive integration, but later realized it cannot handle folders. I only need it for linking project folders, not individual documents, so it is useless to me. I was able to remove access from the Google account, but the field is still showing up in Asana tasks, despite the integration being now disconnected and hence, becoming a useless field.

I was not able to find any information on how to disconnect the integration, and if I click on “integrations” within Asana, it takes me to a paywall about upgrading to the Enterprise plan.

What do you even get with Enterprise for Google Drive?

This is one of the weakest parts of asana, too bad it wasn’t fluid with Workspace and specifically Drive

Hello @Jorge-wms and you have performed this step already?

Going into profile settings > Apps and then deauthorize

Hi @Andrea_Mayer , I tried that too, but the field is still showing up. Now it’s even worse, because all I get from it is an error :sweat_smile:

Very strange. Best to reach out to Asana support so they can take a look and assist

Thanks for the tip @Andrea_Mayer , I reached out to support and they helped solve it.

To close this thread, and in case anyone else runs into the same issue, the solution was to remove the field from the Customize → Apps in the project:


So to summarize, an app needs to be removed from 3 different places:

  1. Remove access from the app itself (Google security screen in this case)
  2. Remove the app from the Asana account’s apps/integrations
  3. Remove the app from any projects where it was used*

*this should be automatic, so perhaps an item for the #forum-en:product-feedback people.

1 Like

Thanks for getting back and updating this thread @Jorge-wms!