No due date order in Android widget

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Steps to reproduce: use the Android widget

Browser version:

Upload screenshots below:The task list in the Android widget is always unordered, which makes it really hard to keep track of important tasks, cause they might end up at the end of the list, even if the due date is today

Hi @David_Hoeck, welcome to our Community, and sorry for the trouble. Just to clarify, does this happen even after you sort your tasks by due date?

To order your tasks by due date using an Android, please go to the project in question ( or to your “My Tasks” list, if that’s where the issue is happening) > click the “toggle” icon at the top of the screen > Sort by due date

Looking forward to your comments!

1 Like

Hi Vanessa,

Yup, I tried to sort it by due date and it will always fall back to custom order.

1 Like

Thanks for confirming that, @David_Hoeck. It’s very odd, we’ve tested the sorting on Android devices and could not replicate the issue. If you don’t mind, I’ll ask you a couple more questions so I can investigate this further:

  • When you choose your sorting option (due date, assignee, etc), are you pressing “reset” in order to go back to the task list? Some users get confused and press “reset” after choosing the sorting, and this brings them back to the previous sorting. If that’s the case, instead of pressing “reset”, please tap anywhere outside the “View settings” box once your new sorting is chosen.

  • If this is not what is happening in your case, please try to uninstall/reinstall your app.

Lastly, if neither of the tips help, I’ll kindly ask you to reach out to our Support Team so they can further investigate this for you. I would recommend sending them the link to this thread, so you won’t have to repeat everything. Also, please provide them with screenshots of the issue, as well as the version of your Android.

I hope this helps, David, and please let us know here in the Forum if the troubleshoots above worked!