New fields created not showing in library - or connecting to form

Briefly describe (1-2 sentences) the Bug you’re experiencing:

I am making a new form. Linking my drop down options for one of the form’s questions to a field, I am experiencing the issue that when click ‘Connect to field > Add field’ and create a new field (also selecting ‘add to library’) it disappears.

The new field doesn’t link my form question options to the field and even when I search the library for the new field I just created, it is not there. I tried multiple times and have used forms and the new field function extensively before without issues, hence now reporting it as a bug.

Steps to reproduce:

  1. Creating a new ‘Multi-select’ question in a form
  2. Editing my question, I click on ‘Connect to field’
  3. I then click on ‘Add field’
  4. I fill in the details for the new field and select ‘Add to library’
  5. I then click on the blue ‘Create Field’ button
  6. My question is not connected to the new field
  7. The new field is not searchable under the ‘Choose from library option’

Browser version: Using the new Asana Desktop App and also just tried in my browser which is the latest Google Chrome Version 90.0.4430.212 (Official Build) (x86_64)

Upload screenshots below:

I have created this quick Loom video showing what happens:

https://www.loom.com/share/75c51e9dc53844489a2d18467955b2b8

Hi,

I don’t know if this is a bug, but you should try to create the field from the list view and then link it from the Form view.

Hi @Wietse, thanks for flagging this! Thanks @Bastien_Siebman for jumping in!

Having tested this on my end, I can confirm it’s working as expected: in the form question, click ‘Connect to field > Add field’ and add this field to your Org library. This field now shows in the custom field library when tested in other projects.

Could you please try the troubleshooting steps below and let me know if any of these resolve the issue?

Looking forward to hearing back from you :slight_smile:

Hi @Wietse, just checking in here to see if you have any updates? :slight_smile:

Hi @Wietse, as I haven’t heard back from you just yet, I’ve gone ahead and moved this thread to #bugs:closed. Feel free to reach out if you’re still encountering this issue :slight_smile: