Microsoft Teams: Can't find project when trying to link

I’ve integrated Asana w/ Microsoft Teams and have added the project tab to the channel, there was no problem. This feature basically mirrors Asana tasks in Teams. But I wanted to configure to get notifications in this channel and when I try to link it, following the instructions found here: https://asana.com/guide/help/api/microsoft-teams#gl-teams it can’t be done. My project which was added to the tab and a number of other projects are not visible, yet some are - all are public to the organization. Any advice is appreciated.

Hi @George_Bugan, welcome to the Asana Community Forum! sorry for the trouble here, let’s try to solve this together!

Can you please send me a screenshot showing the error or issue to link the project?

Looking forward to your reply!

Hi @Emily_Roman, as you can see the autofill does not detect any project beginning with that keyword (there are 2 in Asana). I’ve tried using the full name or various elements of the name but no luck. Few other projects are visible:
Screenshot 2020-10-30 113930

Hi @Emily_Roman, any news here?

So sorry for the delay here @George_Bugan! Since the projects are public in your Organization, you should be able to add them to teams and get notify. In order to solve this issue asap, can you please contact our support team and share the URL of this thread? They are in a better position to give you a tailored answer here and give you the specific steps to resolve this.

I’m having the opposite issue with the Asana/MS Teams integration. I can find the project in the search, but I keep getting an error message when I try to link the project to a channel: “Unable to reach app. Please try again.” I tried several times with a couple different projects as well as uninstalling and re-installing the Asana app. Any suggestions?