"Make subtask of" can't search all tasks

Briefly describe (1-2 sentences) the Bug you’re experiencing:

When I try to “make subtask of” another task, the little search bar where you enter the name of the task you want to move it to won’t find all tasks with that name. I can’t find a way to expand the list to show more tasks. It doesn’t even display the tasks within the same project. It only shows a few subtasks with similar names, and one parent task from a totally different project.
This seems to be a new bug, since I go through this process weekly and have not had this problem before.

Steps to reproduce:
Click into the subtask
Click the three dots, select advanced options, and make subtask of.
Begin typing the name of the task I’d like to make it a subtask of.
The search only comes up with a few possible tasks, but none are the ones I’m looking for. (I know the task exists, because I am looking right at it in the left pane.)
If I tap “enter” instead of expanding the list (like a normal search does) it just puts the subtask into the first task in the search list.

Browser version:

Upload screenshots below:
In the screenshot the task circled in the left pane does not show up in the available options of the search on the right pane. (both are in the same project)

Hi @Mikayla_Santiago, thanks for flagging this!

I’ve gone ahead and raised this with our Engineers. I’ll get back to you as soon as I have an update :slight_smile:

Hi @Mikayla_Santiago, could you please confirm if you can find the subtask when using the searchbar?

Unfortunately the search bar still does not find all the tasks with that name, and there is no option to “see more results.”
I have found a workaround, that if I go into the destination task and make some change (i.e. adding a space after the name or something miniscule) the task will then show up in the search since I recently accessed it. Definitely not ideal, and not the functionality it had before, but I can at least proceed with my work.

1 Like

Hey there @Rebecca_McGrath,

I’m still having this issue. Has there been any developments or Has anyone else reported this bug? Unfortunately my workaround of editing the task name stopped isn’t working anymore. I even created a brand new task, and the “convert to subtask” search doesn’t even see the new task. There seems to be no consistency and it doesn’t happen with every task I’m trying to affect. I am noticing though that the advanced search now isn’t finding certain tasks either. (That might be a new aspect of the same issue.) :woman_shrugging:t2:
Drag and drop doesn’t help, since that just makes them into parent tasks. I can’t just re-create the tasks, since there has been change history, attachments etc. that we need to retain. So all the subtasks I need to re-home are just stuck since I can’t put them into the appropriate tasks.

Is there some other way to accomplish this?

Please and thank you for any help or suggestions

Hi @Mikayla_Santiago, thanks for following up.

Unfortunately, as our Engineers cannot reproduce this bug and no other users have reported this, they cannot find the root of the issue.

I’ve followed up with them to let them know that the issue persists.

Thanks @Rebecca_McGrath , Yea, I can see how they might not be able to reproduce it since it’s been so inconsistent. Hopefully I can figure out another workaround. Thanks for your continued efforts.

@Mikayla_Santiago,

Until this is fixed, and actually in some cases this is a faster approach regardless, use this approach:

  1. Copy the link of the parent task (maybe you’re already starting at the parent so just capture it then, or search for it with the regular search box)
  2. Go to the task to be made into a subtask, choose Convert to subtask from the overflow menu, paste the previously-copied link, click Return

Often this can be more direct than hunting for it in the autocomplete dropdown.

That’s it!

Larry

@lpb Larry you’re brilliant! It worked! This will help so much so I can move forward. Thank you so much!! :raised_hands:t3: :tada:

1 Like

So great to hear, @Mikayla_Santiago–thanks!!