Limited Access Member Can't Trigger Rules

If a Limited Access Member has either ownership or edit access rights to a project that has rules added by a Member, they are not able to trigger rules which runs counter to what the documentation indicates should be possible.

Browser version:
OSX10.15.6 (19G2021)
Chrome 85.0.4183.121 (Official Build) (64-bit)
Firefox 80.0.1 (64-bit)
Safari 13.1.2 (15609.

Hi @John_Turner, thanks for reaching out and sorry for the trouble here!

I just tried to reproduce this from my test account and I was able to trigger a rule being a Limited access member in a Workspace.

Can you confirm if the user that is trying to trigger the rule is a Guest (a user with an email address that is not linked to your Organization)?

Looking forward to your reply!

Hi @ Emily_Roman, thanks for getting back to me. I can confirm that it is a Limited Access Member. I screen shared with this user yesterday and saw this behavior with my own eyes. I then bumped her up to the Member level, and when she tried it again, the rules fired off. Then I bumped her back down again and she was no longer able to have the rules be triggered. We are happy to screen share with someone from Asana to show this behavior with you. You might try having a colleague create a project and some rules as at the Member level, then shift them back down to the Limited Access Member level and see if they can then trigger the rules they created. We only did it in this order as a result of the documentation previously indicating that a Limited Access Member who was a project owner could add/edit/delete rules on that project, which turned out to not be true. More details below:

The utility and distinctions between Members (which really seem to be more like admins given how little Limited Access Members can do - they do seem more like Guests) and Limited Access Members is poorly documented throughout.

Hi @John_Turner, thanks for getting back to me! In this case, I recommend you to contact our support team and share a screencast showing the issue. This will help us visualize the behaviour you are getting. Loom is a great app for video screencasts:

In your video screencast, we recommend that you use a Chrome Incognito window and have your Javascript console open:

Try to include the entire browser window, including URL bar, in the video screencast.

I hope the issue is solved soon! Let me know if you have any other questions.

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.