IPad APP cannot delete project

Briefly describe (1-2 sentences) the Bug you’re experiencing:
iPad app is unable to delete a project.
Also, click on a project, and go back to home, the page jumped half way to recent, (I was on All tab). It looks really weird.
Steps to reproduce:

Browser version:

Upload screenshots below:

HI @Yang_Sun,

Let’s see if we can work this out together. Could you try to delete and reinstall the app on your iPad? If something went wrong in the last update, reinstalling a fresh version could solve this issue.

If that doesn’t resolve your issue, could you answer the following questions?

  1. Are you able to delete this project from the web version?
  2. Are you having this issue with all projects, or is it just with a specific project?
  3. Are you having the issue with WiFi and with 3g (if you share your phone connection for example)?

Looking forward to your reply!

Did reinstall a couple times. Doesn?t work.

  1. I could delete projects from the web version.

  2. It happens to all projects.

  3. I?m on WiFi.

Thanks @Yang_Sun,

Have you tried re-installing the app?

Of course. Tried a couple times. Doesn?t work.

Can you please confirm what version of the Asana app you’re using as well as the version of iOS you’re currently running?

Could you possibly record a screencast to show us what happens when you try deleting a project from your iPad?

Looking forward to your reply!

I’m seeing this bug too.

Asana 8.5.0
iPad Air ME987B/A
iOS 12.4.4

Steps to recreate

  1. Create a new project inside iPad app
  2. Inside project, tap project name
  3. Tap ellipsis in top right corner
  4. In popover modal, Tap Delete project

Expected behaviour
“Are you sure” slide up dialog -> yes
Popover modal closes
Project is deleted
View is returned to home

Actual behaviour
No “are you sure” slide up dialog
Popover modal remains open
Slight visual flicker behind translucent modal
Project is not deleted

Things which I’ve tried which do not resolve the bug

  • Fully quitting and relaunching the app
  • Using a different internet connection
  • Renaming the project before attempting to delete

Addition info

  • The bug seems to be isolated to the iPad app (the same project can be deleted using the web interface and iPhone app (iPhone 6, Asana 8.5.0, iOS 12.4.4)

I made a video of the bug

Asana 8.5.0
iPad Air ME987B/A
iOS 12.4.4

Based on the drop shadow visible in the top left corner after tapping “Delete project” (see video), my guess would be that the confirmation dialog is being drawn just outside the viewport.

Thank you so much for the amazing bug report and video @Will_Rice! :pray:t3:

I just filed a bug there and will update this thread as soon as I have an update!

I’ve discovered a workaround for this bug:

  1. Start with the iPad in portrait
  2. Tap “Delete project” (nothing happens - “are your sure” dialog has been drawn off screen)
  3. Rotate the iPad to landscape
  4. The “are you sure” dialog is now visible on screen
  5. Tap “Delete project” to confirm

Note: Be careful, doing this the other way round (landscape, then portrait) will cause the app to crash completely back to the home screen.

1 Like

Wow @Will_Rice, thank you so much for sharing this! Looks like our team has identified what is causing this issue, so we should have a fix soon; but in the meantime thank you so much for going extra mile and sharing this workaround with us, really appreciate it! I’ll be in touch as soon as I have an update from our team!

Hi @Will_Rice, just a quick update to let you know our team has pushed a fix for this issue; it should be available with the next update! I’m moving this thread to #bugs:resolved-bugs but please let me know if you continue running into trouble after the next update! Thanks again for your help on this bug report!