How to hide subtasks in the "My Tasks" section


#1

Hello!

Please tell me.

I have major tasks. I break down major tasks into subtasks. Here is screenshot: http://joxi.ru/DrlNQOBfV0XPy2

But faced the following problem. When I switch to the “My Tasks” section, all subtasks are shown as separate tasks. Here is Screenshot, what I mean: http://joxi.ru/Y2LyXqQI7QlpqA

It confuses me. Can I hide subtasks from the “My Tasks” section. Or maybe there is a better solution?

Can you please tell me what to do?


#2

Hi Zhan- I’m not a bit supporter of Sub Tasks for a variety of reasons, especially when using searches and reports. However, if you assign your parent task to yourself, but leave the subtasks without assignment, they will not show in your My Tasks view. But, you’ll still see them when you click on the parent which IS assigned to you.


#3

I agree with Mark on this one. Maybe your “major task” should be/could be a project?


#4

I agree - but create a report to do this for you.

  • Create a search for Tasks assigned to you
  • Select incomplete
  • Select due in the next 0 days to only see todays tasks
  • add a filter using the “more” option
  • Click subtasks
  • Select “Not Subtask” in the filter
  • Click Search
  • Save this as “Top level tasks”
  • Drag this to the top of your reports

This solves the problem of other people allocating sub tasks to you - this might happen if you have a task that has 5 sub tasks, 2 are for you and 3 are for other people.

You allocate the tasks to other people and leave yours blank as the parent task is yours. Other people then assign them to you to be helpful … assuming you forgot to assign yourself when you assigned them.

Either works and the report is not difficult to create, so i use both.