How remove time on start date?

Hi,

I want to remove the time from the start date of a task. I save the task by passing a start_on value but the time remains. Even passing the start_at to null it doesn’t work, the date stays the same.

Hi @Lydia_Bell,

Uh-oh, good catch; I was able to reproduce this issue.

@Kem_Ozbek @AndrewWong This looks like a bug to me.

Steps to reproduce:

  1. Update a task so that it has a start_at and a due_at value set on it.
  2. Update the task again with start_on set to a different date and start_at set to null.

Result: the date portion of the task’s start date is updated to the different date you sent in Step 2, but the time is still set and is present in the start_at field.

Lydia, I did find a workaround for now, but of course you shouldn’t have to do this:

In addition to setting start_on to your desired date and nulling out start_at, also save off the current due_at value, then set due_on to the date portion of that value and null out due_at. Save the task. That will remove the time from the start date.

Then immediately set due_at back to its saved-off value.

Hi,

Thanks for flagging this problem! There is indeed a bug here which we will correct, but I also wanted to chime in with a clarification. Similar to the due_on and due_at fields, start_on and start_at are not intended to be used together. When both are specified, the Asana API should have the following behavior:

  1. The start_at field will be ignored entirely
  2. The start_on field will be respected, and the start time of the task should be cleared.

The bug here is that setting start_on does not correctly clear the start time of the task. We will correct this behavior.

Thank you for reporting this issue!

4 Likes

Thanks, @Chris_Cankov, appreciate it!

No problem! The fix for this should now be live.

5 Likes