Google sheets "The number of rows in the range must be at least 1" issue

Does anyone know how to fix this issue?


1 Like

Hi @Gael_Varshavsky what are you using to sync your Asana to your Google Sheet? A 3rd party?

Any feedback on how to resolve this issue?

Hi @anon41849828 waiting to hear bac from Gael. Are you using a third party connector?

I am having the same problem. I am using the Asana Exports app.

Hi @Danielle-GenD, I’m also getting this error. The operational flow is directly from Asana to Google Sheets, with no 3rd party involved. From the Asana project, under export, I do not see an option to export data into Google Sheets anymore. In addition, I went back even further and do not see the Asana Addon within the Google Extensions.

I am also getting this error! Any solves?

@Samantha_Scuderi unfortunately no. After diving through multiple forms for the last couple months & trying different things on my own - I finally reached out to Asana’s support team. Their recommendations did not help me and they’ve elevate the issue to higher support team but no response yet. However, their recommendations could maybe help you so I went through each email and copied and pasted it below. I’d appreciate hearing if this works for you. I hope it does!


Sophie (Asana Support)
Mar 5, 2024, 7:48 AM PST
Hi Paul,
Thanks for writing in. Sophie here with Asana Support. I’m sorry to hear you are having trouble to sync Asana to Google Sheets. I would be happy to assist you.
Thank you for sending the screenshot.
Could you reinstall the Asana Exports add on in Google Drive using this link and let me know if the button “Sync to Google Sheets” appears again?
I am looking forward to your answer!
Kind regards,

Thanks Sophie for the prompt response. I tried this process while recording with Loom to show it did not work. According to this old forum post, it appears Asana support needs to add this option manually?

Hi Paul,
Thank you very much for trying this and sending the video and the screenshot.
We no longer have the option of enabling it. This feature should already be fully implemented.
I suspect that this could be caused by a browser issue.
Please take a moment to try the troubleshooting tricks I’ve listed below:
Test Asana on another supported browser. If it works in Firefox but not in Chrome, for example, this indicates that the problem may be with Chrome, and one of these steps may help fix it.
Disable browser extensions while using Asana. You can test this by using an incognito or private browsing window. This disables browser extensions by default. If it works in incognito/private mode, you may need to try switching off some of your extensions to see if any are causing conflicts with Asana.
Update your browser to the latest version.
Clear your browser’s cache.
If you find that you’re still running into problems, I would highly suggest downloading the Asana desktop App to rectify your browser issues.
If you are using the desktop application, I would recommend uninstalling and reinstalling the app
I would encourage you to try all of the above suggestions. Once we know more, we can investigate further. Feel free to reach back out at anytime Paul, I’ll be glad to help!
Kind regards,

Unfortunately the problem remains after trying the recommended process. I removed chrome, extensions, and the asana desktop app. I reinstalled asana desktop, and i still can not export to google sheets from within asana. I think this is an Asana issue, and not a browser issue. The reason I think that is because I’ve kept the same chrome browser and extension for the last year, even when Asana would allow me to export to google sheets from within asana but since upgrading my asana account to be hipaa compliant, this has been broken. Please help! Thank you

Hi Paul,
Thanks for trying these suggestions.
After checking, it seems that the update to be HIPAA compliant has disabled this feature.
I’ve tried enabling it again, could you confirm if you’re seeing this on your end?
I am looking forward to your answer.
Kind regards,

No notifications, and the problem remains. I’ve checked the admin console, and the app settings. I even uninstalled asana, and reinstalled it to be sure. I also checked via the web app.

Hello Paul,
Thank you for replying and apologies for the inconvenience.
I have escalated this issue to our Engineers and will let you know of an update as soon as possible.
In the meantime, I really appreciate your patience. Please don’t hesitate to let me know should you have any additional questions!
Kind regards,

1 Like

4/15/24 - After 30+ emails, and 6 phone calls I’m so happy this has been fixed. The issue scaled with their software engineers and then global policy (because we have a HIPAA account). So what happened? The export function vanished after we upgraded from Business to Enterprise + for HIPAA safety. Asana can’t be responsible for exporting data incase it’s sensitivity, so they disabled the function. After demonstrating we had a BAA with Google Suites, Asana reenabled the google sheets export, manually. Special thanks to Asana rep, Mrs. Melville, who followed through with Asana and kept me in the loop.

1 Like