Custom Rule - my task is no longer "blocked" by a dependency - but rule won't run

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Custom rules provide the following trigger : “Task is no longer blocked”
I have a task that has a dependency.
When the precedent task is completed the task is no longer blocked.
The rule fails to run.
It appears that the rule is designed to run only when the dependency is removed and not when the dependency is “no longer blocked”

Steps to reproduce:
Set task A
Set task B
Set B to be dependent on task A
Create Custom Rule
Trigger > Task Timing > Task is no longer blocked
Actions > Priority > Set Priority to Medium
Save Custom Rule

Return to Task list
Mark Task A as Complete

  • this should change the task priority for Task B

Browser version: Chrome

Upload screenshots below: Nothing to show - rule doesn’t run.

I just tried and it ran perfectly. My action was to assign the task.

One thing that comes to mind: the task being completed (the trigger), is not completed by a rule, correct? Otherwise, it would not work, a rule cannot trigger another rule.


Thank you - “A rule cannot trigger another rule” That helps. I was able to rewrite the rules to accomplish the same result. All is working now.

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.