Custom fields missing when importing subtasks via CSV

Same here, but i dont have any info in CUSTOM FIELDS when import subtasks. (but dates and Assigne imports fine)
See csv here

@Benjamin12 I’m led to believe there is a separate custom field this data is importing to. Your import image shows the field as a text type, but the data in your post shows colored bubbles which means it is a dropdown type… :thinking:

Sorry, It’s just screenshot from my differents tries.
No matter which custom field you choose, the result is the same
here my csv screenshot:

Thanks for clarifying, @Benjamin12 ! You are absolutely correct! I just re-created what you shared and I got the exact same result. @Marie_OoO and @Emily_Roman is there a way to split off @Vince_Colvin and @Benjamin12’s replies as part of a separate Bug post?

It seems that when importing subtasks it seems the mapped Custom Fields aren’t getting applied even though they should. Below is a capture of my CSV, Import Preview and end result. Thanks!

Hi @Benjamin12 and @Jerod_Hillard :wave:t3:

I’ve moved these posts to a separate thread to follow-up specifically on this question. I’m afraid this is not a bug but an expected behaviour, or a product limitation more precisely. Currently, the CSV importer does not support custom fields for subtasks. The reason is that technically subtasks don’t inherit custom fields from their parent task - in List projects, we’ve worked something out to show custom fields for subtasks, but this fix is limited and not supported by the CSV importer (yet!). I’ve found a task internally escalated by some of my teammates on the behalf of their customer. I’ve added your report to this task and will keep you posted as soon as I have an update on my end! If you haven’t yet, please upvote Ability to import subtasks with drop-down fields via CSV too!

Thanks @Marie_OoO! :pray:

1 Like