CSV Import dependent tasks to a project

This is exactly what we needed. Thanks so much!

2 Likes

Hello, what about multiple dependencies. How can I proceed?

2 Likes

I’m not sure if the Importer supports multiple dependencies or not.

@Marie @Natalia, do you know?

I’d like to know the answer to this question, too. It seems better to reverse this feature and mark an individual task a “Dependency” and enter the name of the task that depends on it, since there may be a many-to-one relationship here. Otherwise we have to enter multiple dependent task names in a single Excel column

3 Likes

This was working for me a couple of weeks ago, now it imports the dependents column, but doesn’t create any dependencies.

It does however create some nice coloured pills down the dependency column as a custom field.

What happened ? It really rocked!

This is happening to me, too. Dependencies aren’t working the way they’re supposed to.

Here’s the vital bit - Fill the Dependents column to list tasks that are dependent on the current row

They should correspond to the dependent task names exactly. The dependent task should be located above the current row in the CSV file. If there are non-unique names in your CSV, the closest row above with a matching name will be used.

If you list a task in the dependents column of a given row, and that task is below the row you’re working on, it won’t work.

I’ve just figured this out - I basically had it round the wrong way.

e.g. Task B is dependent on Task A.

In this case you’d add “Task A” to the dependents column of Task B.

Task A must also be above Task B in the list.

edit - I’ve also successfully used comma separated task names in the dependents column to list two tasks that are dependent on the current task.

In this scenario, you’d have to do that (enter multiple task names into the Dependency column) for a many to many relationship though!

I really appreciate your response! But… When I order the steps as I’m supposed to (upside down, if you will) the field still comes in as a text field and the Dependents option is disabled. I swear I’ve tried this a thousand ways and had a teammate do so as well. I think there’s something up!

Have a look at this example. Open the sheet and then click File, Download, CSV. Then import that CSV into a fresh asana project.

Pay attention to the date field. I’ve formatted this to mm/dd/yyyy as Asana can be touchy about dd/mm/yyyy. The sheet uses references to link tasks (see the formula in the dependents column) demonstrating one to many and many to one relationships.

for this to work you will need to replace your@email.address in the sheet first.

I’ve just tested this and it works for me. YM as ever MV.

HTH

1 Like

I appreciate the example! And I can confirm that your example works for me. When I use the exact same cell reference in my file (up one row to the prior task), it doesn’t work for my file. The Dependents column is recognized as a Text Field and the Dependents option in it is disabled!

1 Like

Can you post a copy of the CSV you are trying to import and a link to the Google Sheet you are using to generate it? It might help find the root cause of the problem.

@David_Ruder You’re so generous to offer! We spent some time cleaning a file for you but in the process, we realized that one can’t use a task name as a dependency if it includes a comma, because the importer reads the comma as a separator. We can work around that! Thank you so much for offering to help!

1 Like

Thank you this is very helpful!!

1 Like

It appears you can only create dependencies to Tasks and Sections already above the current row. No skipping around among sections - create them all in order. Dependencies must flow from top to bottom.

Hi @Phil_Seeman , kindly help me out.
I follow the instructions as the link, its display Dependents in List, but when I go to Timeline, its show as independents task. How can I set its dependencies in Timeline also? Many thanks
In List:


In Timeline

Hi @Trang_Dang1,

The “dependencies” showing in the list view are not actual Asana dependencies (which is why they don’t show as dependencies in the timeline). What it looks like your CSV import did is create a custom field called “Dependents” which to Asana is just a text field that has no special meaning to it.

You’ll need to go back to the import process and figure out what you need to change to have it create real dependencies. I’m afraid I’m not a CSV import expert; @LEGGO, might you have any tips on how to properly create dependencies on a CSV import?

@Phil_Seeman is spot on with what is happening with your import. Now we just need to figure out why that is the case.

@Trang_Dang1 it looks from the image you have done everything correctly as outlined in the Asana Guide, as it pertains to dependency mapping. The main points being that data in the Dependents column should correspond to the dependent task names exactly and dependent tasks should be located above the current row.

If you want to message me a sample of your import file (csv) I’ll gladly take a quick look to see if anything else seems off they might be causing this behavior.

@Trang_Dang1 thanks for sending the CSV file. It appears that the issue is the way in which Asana has chosen to identify when there are multiple “blocked by” dependencies for a task. They use the comma as a delimiter for this so that is why you are unable to select the Dependents column as the one defining how dependencies will be mapped due to the error:

image

In your case, for the “Apply for routine” task Asana thinks there are 3 dependencies:

  • Implement the trial
  • feedback
  • revise

instead of just the one dependency of: Implement the trial, feedback, revise

I have posted this issue here: Unable to map dependencies using the CSV Importer when the "blocked by" dependency includes a *comma* in the Task Name

if you replace your commas with a semicolon or hyphen, for the time being, in your CSV then everything maps perfectly! I do hope this is addressed because I personally think commas are more common when starting actionable task names in Asana. IMO a semicolon would be more appropriate delimiter (or some other uncommon character)

1 Like