Convert task to project rule bug

Hi all,
I’m having an issue with a rule, in a Business Plan instance: I set up a workflow that when a task is moved in a specific section, this triggers the rule to convert the task in a new project.
Everything works as expected, but the task description doesn’t move to become the Project Description in the Overview tab. Everything works if I manually convert the task into a project, it’s just the automation that doesn’t work.
Any suggestion on this is more than welcome. Thanks!

1 Like

I don’t know if this ever worked. @Julien_RENAUD @Arthur_BEGOU any idea?

1 Like

Hey @Emanuele_Rainoldi :wave:

Yes, I notice the same, I think this is simply a limitation of that rule.
However, in the project description, you have a link to access the initial task.

Another limitation of the rule is the template roles (= assignee placeholders) that can’t be used.

As Asana consultants, we sometimes advise keeping the process manual (= manually convert the project to a task); instead of using the rule.

Hope that helps :wave:


Thanks @Arthur_BEGOU and @Bastien_Siebman. It’s good to know that this is an actual bug and I’m not missing anything, and thanks for the suggestion of keeping the process manual. It could be useful for a double check before creating the project.

1 Like

Hi everyone, sorry for the trouble. I’ve tried to replicate this on my end and the task description became the project description in the Overview tab once the rule converted the task into a project. Can you test again today and let me know if the issue persists for you?

1 Like

Hi everyone! We couldn’t confirm this bug on our end, so I’ll close this topic, but if you are still running into issues let me know and I can reopen it :slight_smile:

Hi @Vanessa_N, thanks for checking. I tried again and it seems everything works now even with the rule, you’re right. I think the issue ca be closed.

Thanks again!

1 Like

Thanks for confirming, @Emanuele_Rainoldi! :slight_smile:

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.