Completed Task | Untick and then re-tick does not update the task complete time, and does not trigger webhooks

I use Zapier to run some task automation once a task has been closed. I need to re-run some of these, but when I untick the task and re-tick it, the task state does not appear to change so Zapier does not pick it up.

What happens is that when I untick the task it shows my name and marked as incomplete. If I retick it, this disappears and the old completed by line shows, but nothing states that I have completed it again. This does not then trigger in Zapier

My guess is that the change happens too fast and Asana does not re-trigger webhooks on purpose. @Phil_Seeman what do you think?

@Martin_Parkinson can you uncheck, wait a few “hours” and recheck?

Thanks Bastien … I tried for about 20 minutes as I thought it may be something like that, but will try one for overnight and see what happens in the morning!

No, I just tested and that’s not what I’m seeing. When I take a completed task and unmark it complete and then within a second or two I mark it complete again, I get a webhook with two “Task changed” events in it.

@Martin_Parkinson, you said one thing which seems odd to me and is not what I’m seeing:

I assume you’re referring to the activity list in the task detail, correct?

The behavior I get when I try this is:

My activity list initially shows “Phil Seeman marked this task complete 5 minutes ago.”

When I unmark it complete, that line disappears; when I then immediately mark it complete again, it reappears and now says "“Phil Seeman marked this task complete just now.”

Are you saying you’re seeing something different from that?

Also: are you doing this on the Asana web app (i.e. not mobile)? I just want to make sure I’m testing on the same platform as you.

Hi Phil
Yes, on the web app. This is a task that was completed some months ago. If I look at the task, it says “Mike Ryan completed this task 20 Jun” . If I then untick it, I get a new line: Martin Parkinson marked incomplete.
Just now

Right - but you’re saying you’re then immediately marking it complete again and that action is not reflected either in the activity list or via Zapier? Or am I misunderstanding your original post as to what the issue is?

Yes I am marking as complete again (either immediately, or 20 mins later) and the complete goes back to 20th June (as though I had not unticked and then returned again) and nothing reaches Zapier. If I complete another task that had not been previously completed then Zapier triggers.

Hmm, I’m stumped. @Marie or @Natalia, any idea why this would be behaving properly for me - when I re-mark the task as completed, it updates the Story and sends an event; whereas it behaves differently for @Martin_Parkinson - it does not update the Story and does not generate an event?

So maybe Zapier is doing cache in some way?

No, the finger seems to be pointed at Asana. Based on @Martin_Parkinson’s description, Asana itself is behaving incorrectly for him and inconsistently with how it’s behaving for me (which is in the correct way).

1 Like

Yes, immediately marking complete again, and the completion date remains as it was previously. i.e. the task was completed on 20th June, untick it and it say that the task was marked as incomplete today. Then tick it again and this line is removed from the task activity and the task completion line remains at 20th June. Zapier when it polls for recently completed items does not pick it up. I have tried unticking and waiting half an hour and and then reticking and it still does not reset the completion date. It may be that Zapier is a separate issue, I cannot really tell at this stage, but the activity stream is not correct on the Asana task so I still think something is not right there. If I tick a task that has not been previously completed, everything works as it should.

Hi @Phil_Seeman and @Martin_Parkinson,

I believe our team is aware of this issue with Zapier, but let me find out more and come back to you!

Thanks Marie - I have got a little more information. You need to leave the task unticked for over an hour, then when you retick it the activity stream updates correctly and shows the later completion date, however Zapier still does not pick it up, and I think the completion date on the record is remaining as it was before in the background.

Hi @Martin_Parkinson, :wave:

I am Alexia from the Asana support team, nice to e-meet you! :slight_smile:

I have looked into the thread and thanks for all the information you provided.

Given the fact that Asana seems to behave the right way with stories (we would usually advise to wait at least a couple of hours before undoing an action so that the story is kept on the task), it seems that Zapier is not catching the new event on the task even if it is recorded in Asana.

For this reason, I would recommend contacting Zapier so they can check and look further in their system to understand why the new event coming from Asana did not fire the Zap.

Could you please keep us in the loop once you have more information?

If Zapier gives you an update involving us checking in our system, do not hesitate to contact the Asana support team (How do I contact support) so we’ll be able to investigate further for you, Martin.

In the meantime, have a nice day!

2 Likes