Can I hide a portfolio custom fields from portfolio projects?

Hello,

First post here!

I have recently undertaken the initiative to move our project management reporting into Asana. My plan was to add our projects to a few portfolios and add a number of customised fields on a portfolio level which would include data we would like to report on. However, the challenge I am facing is that a lot of our projects are customer facing within Asana and we would not like our customers to see internal information. Is there any workaround we could apply here? I am open to using a different approach as well if you have other suggestions.

Thanks,
Yolana

Welcome, @Yolana,

I think I have your answer here:

In short, use non-org-wide portfolio-level custom fields, not org-wide ones.

Could I ask you to verify this still works, since my post is over a year old, and report back here if you’re willing?

Thanks,

Larry

1 Like

Hi @lpb ,

Thank you for helping out! I just tried your suggestion and it is either not working anymore or I am doing something wrong. When you say to use a non-org-wide field, do you mean to create if from the ‘Add field’ plus sign within the portfolio?

Thanks,
Yolana

@Yolana, Yes, you create it there, or via the Customize menu, but either way you see this;

The key point is: Leave unchecked the first box: Ad to 's field library. That will make it non-org-wide.

Hope that makes more sense,

Larry

1 Like

Thank you @lpb ! Problem solved - it worked!!!

As I have already done some of the work, do you happen to know if there is a way to remove existing custom fields from the library or do I have to create them again at a portfolio level?

Thank you,
Yolana

Great! And thanks for reporting back.

You may not be able to remove the fields from the library but I’m not positive; I know I’ve been prevented from doing so in some circumstances but not 100% you never can, so you could try it:

Go to an existing portfolio or project that has the custom field and edit it (Customize > hover the custom field and a pencil icon appears > click it). Try to uncheck the box for Add to org’s library. If you can’t you’ll have to create another (optionally removing this one if it doesn’t adversely affect other usage).

Hope that helps,

Larry

Thank you @lpb - you have been super helpful!

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.