Any way to hide the empty "No value" column in board view grouped by single select field?

Hi. I have just discovered how to have the Board view show columns based on a Status and keep the List view as your own custom sections. Brilliant!! We can move tasks through the project stages without affecting how we categorise the task in the List view.

BUT something is bugging me. I can’t seem to hide the “No value” column.

I have set the view to filter tasks by Status (a single select field) and chose the statuses I want, yet the No value column is still there even though its empty. If I create a status called “NA” (or anything to represent None) so all tasks have a status, the column “No value” is still there. Even though there are no tasks with no value.

I cannot re-order it to the end of the columns. There is no hide option. It seems that its fixed.

So I have this annoying empty column on the left wasting my previous space. See attached
(ignore the fact In progress and Review is empty, I have only just created it! :grin:)

Is there a way to hide it?


Actually I have figured out how to do it now anyway.

I had some completed tasks which I usually hide, so I could not see them anywhere. It occured to me they would not have a status as I only just added that field. So when I assigned status “None” to them all, the column disappeared.

The good thing about using this other status to hide things is if anyone adds a task without any status now, it appears in the board view “No value” which prompts us to give it a status (even though it may be None). Thats a good thing.

Although I do think if you have filtered Board view to only show Completed tasks then it should also hide the empty no value column. I can understand it may be tricky though because you would not want to hide any other status column just because its empty. You kind of need a filter for each columns!

Anyway, this is great now I know what do.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.