Webhook Not Working

I am un able to fetch data from my webhook. I started from July 16th onwards, earlier it was working fine. I have attached the json error I received. I even tried to delete the webhook through with it’s gid but received following error.

PS: The error is coming on this particular webhook

“asana.error.ServerError: Server Error: Oops! An unexpected error occurred while processing this request. The input may have contained something the server did not know how to handle. For more help, please contact api-support@asana.com and include the error phrase from this response.”

This error is coming on this particular webhook. I tried deleting another one and I was able to delete.

=====500 Error=====

asana.error.ServerError: ServerError: Oops!Anunexpectederroroccurredwhileprocessingthisrequest.Theinputmayhavecontainedsomethingtheserverdidnotknowhowtohandle.Formorehelp,
pleasecontactapi-support@asana.comandincludetheerrorphrasefromthisresponse.‘gid’: ‘1200’,
‘active’: True,
‘created_at’: ‘2021-06-14T06:21:55.514Z’,
‘last_failure_at’: ‘2021-07-20T06:57:12.107Z’,
‘last_failure_content’: ‘HTTP 500\nx-powered-by: Express\ncontent-security-policy: default-src ‘none’\nx-content-type-options: nosniff\ncontent-type: text/html; charset=utf-8\nX-Cloud-Trace-Context: dc4dff40945df635e5d49ef356f60c07;o=1\nDate: Tue, 20 Jul 2021 06:57:12 GMT\nServer: Google Frontend\nContent-Length: 148\nAlt-Svc: h3=":443"; ma=2592000,h3-29=":443"; ma=2592000,h3-T051=":443"; ma=2592000,h3-Q050=":443"; ma=2592000,h3-Q046=":443"; ma=2592000,h3-Q043=":443"; ma=2592000,quic=":443"; ma=2592000; v=“46,43”\nConnection: close\n\n\n\n\n \nError\n\n\n

Internal Server Error
\n\n\n’,
‘last_success_at’: ‘2021-07-16T08:00:41.930Z’,
‘resource’: {
‘gid’: ‘1200’,
‘name’: ‘My Project’,
‘resource_type’: ‘project’
},
‘resource_type’: ‘webhook’,
‘target’: ‘https://url’,
‘filters’: [
{
‘resource_type’: ‘task’,
‘resource_subtype’: None,
‘action’: ‘changed’,
‘fields’: None
}
]
}

Hi @Amit_Sharma,

What’s the error phrase that’s returned with the error?

It’ll be a nonsense phrase something like “six large sloths rested quietly”. That can help the Asana techs identify the source of the issue.

1 Like

Hey Phil,

Thanks for the response but unfortunately I have not received such phrase.

Regards

@AndrewWong @Ross_Grambo any ideas here? I’m stumped.

Hey Phil,

Thanks for your response. I am able to resolve the issue from my end. I changed my PAT and pulled all the events manually from the webhook. After that I was able to delete the webhook through API call and created a new webhook for that project. It’s all flowing fine now.

Regards,
Amit Sharma

1 Like

And here is the phrase for delete Api call I received earlier.

phrase":“32 needy badgers feed poorly” :grinning: