Vimeo Links not working


until a few days ago I was able to view and share my videos in Vimeo.

I tried to share/view in Vimeo a video recently and realised that I am only getting link to my account but not to the video URL itself. e.g. I am getting this:

Instead of something like this:

Please advise.



Welcome to the Asana Community Forum @Dimitris_Vayenas :wave:

Can you please elaborate this in more detail or share some screenshots (blur confidential data) because the urls you pasted seem to be private so nothing shows.

If there is a problem regarding Vimeo specifically I recommend reaching out to their support.

1 Like

Hello @Andrea_Mayer !

Thanks for the reply and my apologies for the delay in responding. Here is the issue:

So I am recording a video and what used to happen was to be able to share. Now instead of providing me a link to the vimeo/account/videoid I am only getting a link in the form vimeo/account - so no link to videoid.

I do not think that this is a case of vimeo but of asana api failing to include in the link it generates the id of the video.

Here is the other photo I was unable to add (as a new user).

Hello @Dimitris_Vayenas,
I have tried to reproduce this on my end however it is working fine. What I can potentially think of is that you have 2 vimeo accounts and the one connected to Asana is not the one you are signed in to when you checked the link? Or that you are signed out when you checked the link and the video is set to private.

Maybe try reconnecting Vimeo to your Asana account and try again. Otherwise reach out to support so they can look into this as well :slight_smile:

1 Like

Yes, it is what you suggested.

When I authorized asana with vimeo I was in a friends browser. So I authorized my asana account with their vimeo account the browser was logged in at the time I guess.

The problem is that I cannot de authorize Vimeo from the Asana end! I have to figure out the Vimeo Account to de-authorize Asana. Which is funny.

I will write to support to try to de authorize me so that I can then connect with my proper account.

Thank you for everything!

Hiya, Newbie to the forum here so I hope I am in the correct spot … I am a regular Asana user and have just tried the ‘record video’ option inside a task comment but the link to vimeo doesn’t seem to work.
I record my video, no problem but once I stop the video (click stop sharing) nothing happens ? No video is saved and nothing is added to the comment box of the task? I can’t see any connection to vimeo … do I have to create a vimeo account and connect it to Asana? When I login to my vimeo account there doesn’t appear to be any option to link/connect to Asana ? There are 3rd party apps listed but not Asana? Neither do I see any option in Asana to link to my Vimeo account?
Yours confusingly

Hello @Diarmuid_O_Donovan,

you can find some more info here
Are you a full member of the org or workspace or a guest user?

If you are a full member you should be able to record up to three videos without creating a vimeo account. From the 4th you‘ll have to sign up to a free account at least, more here.

Are you using Asana web? If so try to clear cookies etc then logout and in and try again