Slack notifications stopped

We are not getting notifications in any Slack projects since yesterday 28th Nov. 2023, morning. We have checked all same /asana settings, showing the notifications are ON. No one in the entire workspace is getting notifications. Even people working from home are not getting. Every channel is like this. Everything was the same; we didn’t change anything. Without notifications, there is no use of this application.

Please help if anyone has an idea about this. TIA.

Our Asana projects linked to certain Slack channels are no longer updating with in the Slack Channels. This integration seemingly broke at some point yesterday.

I’ve already revoked access and removed Asana from our Slack and then added it back. That’s done little to solve the issue.

This is impacting our workflow and I’m hopeful someone can help us. This suddenly a bug others are experiencing?

Welcome, @joel6,

I’ve merged your post into an existing thread where you can stay updated when it’s looked at.



Thanks, @lpb.

We are still experiencing this and it’s really impacting our workflow. Was hoping this would be resolved within 24 hours and seemingly it hasn’t. Any insights here? Don’t want to say glad to see others are experiencing this, @Satish_Dhiman, but good to see we aren’t alone here.


Hi everyone, sorry about the hassle. I have escalated this case to our Developers for investigation and hopefully I’ll get an update soon. I’ll keep you posted.


Thank you, @Vanessa_N! Incredible what this has done to our team’s workflow. Never realize how streamlined you’ve made things until suddenly something breaks. Here’s hoping it’s a simple fix and back up and running quickly.

We chose Asana in 2020 and never had an issue like this. It’s 4th day ending with no notification in the linked project on Slack. There is a significant impact on our teams, making work slower than expected.

There is no help from the support team; we can only hope for a single reply in a single day and the exact phrase of answer in every ticket.

We have tried everything related to linking projects and notifications. Please help guys if anyone has a clue what’s this.

Hi everyone, our developers have rolled back an update that caused this issue, so notifications should be working now. They are still investigating the root cause to make sure it doesn’t happen again. Apologies for the hassle, and let me know if you are still running into issues

1 Like

Thank you Vanessa_N. Notifications are working fine now. Thanks for this big help. I couldn’t express how helpful this is. joel6. I hope your issue is also resolved now.

@Satish_Dhiman what did you all do to get notifications to work again?.. they still aren’t working here.

@Vanessa_N, what do we need to do on our end to get notifications working again? I’m seeing Satish_Dhiman says his are working for their team, but ours have not returned. I just deauthorized and then reauthorized Slack and Asana connection, and that didn’t do it. This is just killing us here.

@Vanessa_N to be clear, Asana notifications in Slack are fine…within the Asana App. But zero notifications are coming into Channels which are linked to projects. Desperately need the notifications within the Slack channels corresponding to the linked projects.

joel6 I have linked all the projects again, and notifications have started. Every project and people in the projects are good now.

@Satish_Dhiman I got all the projects to work but then the Asana “app” feed stopped working. Then removed it all and it’s all broken again.

What an absolute utter waste of time this week. Beyond frustrated here at the hours spent on this.

Still futzing with it over here…

@Satish_Dhiman @Vanessa_N we’re back in business over here it looks like! Thank you Vanessa for championing this and getting things moving/working again. And thanks Satish for banding together with me to voice things are broken. Hope you both have a wonderful weekend.

Hi @joel6 , sorry for the delay! I’m happy to hear that everything is okay for you now! Sorry for the hassle, and hope you have a nice weekend! :slight_smile:

1 Like

Asana Slack integration has stopped working. Did another deployment go out and break it again? I’m simply trying to create a task in Slack, and I get the message Sorry, that didn’t work. Try again?
It doesn’t work if I try again. Also, I disconntected Asana from Slack and then reconnected it and it still doesn’t work. Help!

hi there - also having issues with asana / slack integration and the notifications being broken. i have removed and re-added the app multiple times with no result. how to fix?

Hi everyone, sorry to hear that you are experiencing the issue again. Checking with the team, we haven’t received similar reports, and no changes have been made recently. Would you be able to test both options below and let me know if the issue persists? This will help our Developers investigate the problem further:

Option 1: Reinstall the Asana for Slack integration through Asana.

  • Click your profile picture in the top-right of your Asana window
  • Navigate to My Settings
  • Click the Apps tab
  • Under Authorized Apps, click Deauthorize beside the entry for Slack
  • Enter /asana settings again and click Connect Asana to Slack to reinstall the integration

Option 2 : Reinstall the Asana for Slack integration through Slack.

  • Type /asana settings into any Slack chat or channel
  • Options are displayed to you and are not visible to anyone else
  • Click the red Deauthorize button to uninstall the Asana integration
  • Enter /asana settings again and click Connect Asana to Slack to reinstall the integration
1 Like

thanks - option 1 appears to have worked. we’ll see if messages start to come through.

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.