Remove notifications when a team member completes a task

Out inbox gets cluttered with notifications about team members completing a task. Please remove tis feature as it is very time consuming going through all these inbox items on a daily basis.

Hi @Holly_Penney,

no need to remove this! You can just turn off notifications. :wink:

  1. click on your profile picture
  2. navigate to My Settings
  3. navigate to the notifications tab
  4. manage your settings
  5. scroll down and manage settings for individual projects
2 Likes

Ya, it doesn’t work!
I’ve been working with an asana specialist and they told me I can’t change this, and to create this ticket.
But now you’re giving me conflicting information… interesting.

Thats strange… Seems to work fine on my end.

So, just to understand you correctly, when you turn of notifications you still get notified?

Other Options: Turn on the Filter in you Inbox

More Infos on Notifications: Email notifications from Asana | Product guide • Asana Product Guide

That’s correct!

I spoke with Dia, and she said they are not looking to change this feature anytime soon in Asana, so for me to create a suggestion.

I don’t know if there’s a glitch in my Asana, but I still get every single notification when a team member completes a task.

Dear,

In my inbox I see completed tasks of others: How can we auto archive thoes?

I don’t care about completed tasks of others in my “inbox”. I manage the project via the task list and when tasks are completed… They are completed. Now I still see them in my inbox. And only by manually archiving them, they are gone. This action is nuts.

What is the solution? Any feedback is welcome.

Thanks.
Niels

Hello Niels,

The reason why you see the completed tasks for others is because you are a collaborator on the task. If you want to avoid this in the future, make sure you unfollow the tasks themselves when finishing the work from them.

Currently, there is no auto archive feature.

2 Likes

Here is an open suggestion for the same topic Niels you can upvote:

What is the solution??

There is no solution at this moment. Only press: Archive notification.

Hi @Holly_Penney , & @Niels_Oomen , the solution was provided by @Rashad_Issa above.

You basically need to remove yourselves as task collaborators. You can do this manually by 'X’ing your profile photo at the bottom of the task. It is like being able to opt-out of an email thread (which you can’t).

Another way is to understand why you are added as a task collaborator in the first place. Were you @ mentioned by someone or took part in the conversation? Are you being added automatically by a rule or a task template? If you dig in with your project creators to find the root causes, you will likely be able to cut down on your inbox notifications.

2 Likes

I have also desactivated the notification for ‘task status’ and keep receiving all of them. I am a PM meaning I am the one assigning task but I do NOT need status update on the task. But as I assign the task, I automatically become a “collaborator” and receive this notifications.

IT IS SO ANNOYING ! It is filling my notifications inbox with useless updates. As a PM the most important for me is my colleague’s comments and it is so much hasstle to go through this inbox and keep archiving 90% of what I get instantly. It brings no value.

I just dont understand why Asana does not just let the USER CHOOSE exactly what kind of updates they want.

instead we can only select huge categories (they put in the same basket “task update” and “@notifications” which clearly needs to get separated!)

anyways asana notifications are the WORST

Have you checked the Notification Tab in your Settings?
You can manage all your Notification there.
You can even change the settings for individual projects!