Notion Links in Asana not working

Hi! We recently started using Notion and I got the Asana integration setup (both linking Asana database and Asana tasks) in Notion and also wanted the Notion integration on the Asana side. I got that added, but not all Notion page links are working in Asana.

We have Client dossiers in Notion and a db for clients and then when you open a client entry from that db it has a bunch of info for that particular client. We want to link that Notion page to the Asana onboarding task for new clients, but get an error message (" Something went wrong. Try again later or contact support.") when adding that URL to the notion field in the Asana task. Can we not link a page from a db entry in Asana? I can share the page URL if needed.

I tried reaching out to Notion first, thinking the error may be on their side, but they said to contact Asana about their Notion integration and why it’s not recognizing the page URL like it should.

I’m seeing the same issue, but my error message says: “URL must be for a page, not a database.” even though I’m definitely linking to a Notion page. My pages are part of a database and it’s erroring out.

I never heard anything here and opened a ticket with support on 4/18. This is what I know “There looks to be an existing escalation with this error message, so I’d like to add your case to see if our team is able to get to the bottom of this issue.”

Asked for an update this week, but nothing new from engineering.

I am having the same issue - this is the error message I am getting “URL must be for a page, not a database”.

I’m having a similar issue. When I try to enter the link from a database from my Notion I received the following message: “Enter a valid Notion URL” but I’m sure the URL i’m inserting is valid.

Anyone experiencing something like this? How can I solve this?

I still haven’t gotten an update on the bug that I filed and it’s still broken for me, weeks later. This thread is just validating that it’s broken for others too. Hope to have it resolved soon :woman_shrugging:

Hi all — I was experimenting with the URL in the asana field, and it seemed as if the URL was just too long. So I tried with just the file path:

/username/f7f7e30ec9ef4ae2bed1b23de671c912?v=5bb644b5f4684d239ab8b81c546fac00&pvs=4

This actually worked! Created the document in Notion almost instantly. Try it out!

2 Likes

Thank you so much. This worked for me, as well!

The user path does not work for me. Any other solutions?

That didn’t work for me either. I worked with Asana support for awhile to make sure the bug got fixed and it should be. You may need to completely remove the link and re-try it. That worked for a stubborn link of mine, but the rest added fine on the first try.

I’ve found that sometimes it will come up with an error but it actually links the Notion page and when you click on it, it takes you to the page in Notion

In my case I had to allow sharing of the page in Notion first.
Go to the “…” of the page or a parent of the page you want to link and select “Add connection”.
Then allow access for “Notion for Asana”.

This did it for me.

1 Like

This worked for me. It was a combination of making sure the page was connected and chopping the front off the link. Nice find!