Middle-clicking A Link Not Working In Task Descriptions And Message Box

Using the middle-click on my mouse (Windows 10; Chrome browser) opens a link in a new tab, as long as those links are in task comments. The middle-click doesn’t work on links in task descriptions or in links in text in the comment box that hasn’t been submitted.

Is this expected behavior?

Hi @Will_Reade :wave:

I’ve just tested myself and it seems to work fine for me when clicking on links in the task description as well as in a comment that hasn’t been yet submitted. Let’s see if we can work on this together:

  1. Would you mind testing this while using an incognito windows ?
  2. Could you also test it in a different browser and let me know if you get the same behaviour?

Thank you! Looking forward to your reply!


I tried it in an incognito window. Still doesn’t work. Just to be clear, middle-clicking does work on links in submitted comments and project names, both in the task list and in the task details.

I tried the middle-click in Firefox. Instead of opening a new tab, it changes the current tab to the link that was clicked. In other words, it is technically working in Firefox, although I argue that it is still not working as expected.

Does that help?

@Natalia, any update on this? Thanks!

I contacted support because I hadn’t received any other responses via this post.

Support said “that this isn’t a bug, but a feature that wasn’t built into Asana yet. They are considering implementing it” but don’t have a date at this time.