In inbox, archiving a long expanded item makes the viewport scroll incorrectly

Briefly describe (1-2 sentences) the Bug you’re experiencing: In the inbox, if you expand a large item thats longer than the inbox’s visible vewport, then archive it, the item disappears, but the inbox viewport also scrolls down, probably to where the item ended. This generally scrolls past other items, so you have to scroll back up to see them.

My normal inbox flow is, I read each item, then archive it, one by one. I often have longer items that I epxand to read, so this happens regularly and disrupts that flow.

(Thanks for building and maintaining Asana, btw! It’s great!)

Steps to reproduce:

  1. Generate an inbox with text that’s longer than the inbox’s visible viewport, then a few other items.
  2. Scroll to the top of the inbox.
  3. Expand the first item.
  4. Archive it.

The viewport will scroll down.

Browser version: Both Firefox 89 on macOS 11.4 and official Asana desktop app.

Upload screenshots below: I don’t have any that are ok to share publicly, but let me know if you need them (or a video) and I can try to generate some with fake data.

Hi @snarfed, thanks for flagging this!

Could you please try the troubleshooting steps below and let me know if any of these resolve the issue?

If not, some screenshots or a video would be very helpful!

Looking forward to hearing back from you :slight_smile:

Thanks @Rebecca_McGrath! This bug reproduces in both the official desktop app (ie not in a browser) and in multiple browsers, including ones that are fully updated, cookies cleared, and no extensions, so it doesn’t seem browser or environment specific.

Here’s a video of it happening. (Hosted elsewhere; I tried to upload here, but evidently this forum currently only allows image uploads, not videos.)

Thanks in advance!

Thanks for getting back to me with this video, @snarfed. I’ve gone ahead and escalated this to our Engineering team. I’ll get back to you as soon as I have an update :slight_smile:

1 Like

Hi @snarfed, thanks for your patience here :slight_smile:

Our Product team has confirmed that this is not a bug but is working as usual. They have, however, noted that it is a bit confusing and annoying to scroll and hope to update this in the future :slight_smile:

Thanks for the update! Surprising that this is expected behavior, but good to hear you all hope to make it less confusing/annoying. :crossed_fingers:

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.