How to copy links on mobile and create hyperlinks

Hi there.

Few thing regarding Asana app on iPhone.

Please give us the ability to:

Delete activity comments (such as “ you added due date “ )

Copy links in task, when we press and hold them

Give ability to create hyperlinks - type in name description for web link

When in a Project, display the team name please - I have the same project name for more than one team.

Hi @nyprosell, thanks for your feedback!

Since we recommend creating one thread per feature request, I’ve gone ahead and splitted your feedback in these threads:

In regards to your question about links and hyperlinks, can you confirm if you are trying to add and create them from iOS or Android?

Lastly, can you also give me more details about your last request? I’ll be happy to investigate further.

Looking forward to your reply!

Hi Emily,

Sorry I didn’t make four post, I figure they are all features people would want. But I will break them all up tonight.

And yes -

Ability to copy links in task iOS. If you press on a link, it just pops up then back down, this would be a good functions that by pressing down the link it will auto copy. When I try to copy links, I frequently accidentally access the link.

And yes, ability to create a hyperlink in iOS

Thank you
Ny

Hi @Emily_Roman

I encountered the same issue this morning when I wanted to copy or open a link from my mobile phone.

I couldn’t copy or open the link until I realized that it was due to the fact that I am “Comment only” in the project settings. I tested and the copy works once you are allowed to modify the project.

I have done the same tests from the PC version:

  • in “Modify the project” view, no problem.
  • in “Comment only” view: if the link is in a custom field then I can’t do anything from the list view. But by opening the task then I can open the link.

Is this behaviour voluntary?
In my opinion, being in “Comment only” should not prevent you from opening a link or copying it.

Hi @Julien_RENAUD, sorry for the late follow up here! I’ll investigate this further and I’ll get back to you as soon as I have more information :slight_smile:

1 Like

Hi @Julien_RENAUD, I tested this and investigate it further but I was unable to reproduce the same behaviour. In this case, can you please try uninstalling and reinstalling the Asana app? as this usually solve this type os issues.

In this gif I click on a subtask and it opens and if i also click on the URL above, it also works:

If the issue persists, please send me a screencast and confirm your Asana app version and OS type and version :slight_smile: Thank you!

@Emily_Roman Have you tried with a link in a text custom field?

Hi @Julien_RENAUD, sorry for the late follow-up here! I see what you mean, the option to open URLs from fields is currently not supported on mobile. However, you should be able to open links when they are added to the task description or comments.

As I said in my post, it is possible to copy from a mobile, but the project must not be “comment only”. And my point is that we should be able able to copy in both cases: “comment only” or “public”.

Have you been able to reproduce this behaviour?
You can try:

  • create a project, with a custom field with a link
  • make the project “comment only” for other members
  • only those who can modify will be able to click on the link from a cellphone

With “comment only” access I can’t click on the link or event select the link:
image

With “can modify access” I can select the link and open it via Chrome:
image

Got it @Julien_RENAUD! I thought you were trying to tap the link to open it on a new tab on mobile. You are absolutely right, I just tested this and I can only select and copy the test on the field if I have edit access in the project. I’ve gone ahead and escalate this question to our product team to confirm whether is expected behaviour or a bug!

1 Like

Hi @Julien_RENAUD! Our team confirmed this is not a expected behaviour and they will work to solve it. Although we don’t have a specific date when this issue will be solved, I’ll keep you updated! Thanks again for reporting this!

1 Like

Hi all, our team has confirmed this should be now fixed in the next Android release 8.48! You will have to double-tap the text to get the selection cursors :slight_smile: Let me know if you have any questions or feedback!