Drag and drop is super slow in Firefox

Dragging and dropping cards on the board has been super slow on both the board for a while and the list view. The the card movement lags behind my dragging actions and it continues to move very slowly seconds after I release the mouse button. It looks like it is slowly processing hundreds/thousands of move events that are being queued up. I use Firefox nightly builds and this affects all recent builds in the last three months and probably before that.

Expected behavior would be for this to be 100% lag free in all modern browsers.

This is completely unusable in its current form. I work around it by going to the card details and selecting the right section from the drop down.

Hi @Jilles_van_Gurp1, welcome to the Asana Community Forum! sorry for the trouble here, let’s try to solve this together!

Can you please try these troubleshooting tips to see if they will resolve your issue? If the issue persists, I recommend you to contact our Support Team so they can investigate this further.

Let me know if you have any other questions!

Hi Emily, thank you for your quick reply.

With all due respect, I’m a web developer and I’m reporting a (serious) bug with your product and not experiencing a self inflicted problem. That is to say; I know what I’m doing.
Just to completely cut off this line of reasoning: I’m using a very recent version of a browser that you support on a corporate network with very excellent network latency & bandwidth (I’ve experienced this on all networks where I’ve used Asana). There’s nothing wrong with my laptop (a fast top line mac book pro), connection, etc. I use gazillions other web apps as well. My browser supports all the latest TLS protocols.

So, please pass on my feedback to your product team. Frankly, I’d be very surprised if they were not already aware of this. But if so, I’d be happy to support them and demonstrate how just how bad this is on a video call or provide any other kind of feedback (javascript console logs, etc.).

I’d appreciate acknowledgement of this issue being tracked & confirmed on your side and some level of commitment to making this better. As this is absolutely a core UX feature of your product, I’d expect this to be nothing short of a bug with the highest level of priority.

Hi @Jilles_van_Gurp1, thanks for getting back to me and providing more context about your report. We really appreciate it!

I’ve gone ahead and sent your report internally and a member of our Support Team will reach out to you directly so we can investigate and solve this issue.

Thanks again for taking the time to share this with us! Let me know if you have any questions in the meantime.