Deleted Goals - still getting tasks & reminders

I setup goals to show a client how they work as an example. Then I deleted them. Now I’m getting reminders for these goals, but they don’t show up in Goals - only if I click the link in the task.

This is what I’m getting: Loom | Free Screen & Video Recording Software in the task.

I tried deleting the goals one by one from the links last time and that still doesn’t work. it creates “Private Link” to the goal that says I have no access and I can still click on the original link and see the goal. And then still sends me a reminder to update the goal - despite nothing to update in the Goals section.

Can anyone help?

Hi @Ray_Green, thanks for reaching out :slight_smile:

In this case, I suggest contacting our Support team as they have access to additional tools that we don’t have here on the Community team to be able to look into this further for you.

You can reach out to them by following the steps below:

I hope this helps! :slight_smile:

This topic was automatically closed after 6 days. New replies are no longer allowed.