"default_access_level" not working

I’m trying to create a new project with a default access level of admin. The object I create is:

const projectData = {
        name: `${ number } - ${ client } - ${ description }`,
        default_access_level: 'admin',
        owner: ingmanagerid,
        team: teamid,

Everything goes well, except the default access level. It still is editor, instead admin as I want. Please, could you help me? What am I doing wrong?

@John_Baldo @John_Vu maybe you can check this out?

Hi @Iván_Chao,

Welcome to our developer community. From what I understand it seems like you are trying to make an API call to our Create a project endpoint and when you tried to create a project with the default_access_level access level as admin it does not get set but the project still gets created.

Could you share more snippets of your code like the part making the request. Also, it looks like the sample code you provided is in JavaScript. Are you using our node-asana client library? If so what version?

1 Like

Hi @John_Vu

I’m so sorry. Reviewing the code to give it to you I’ve found the error. I don’t use the node-asana client librery. I use a fetch function directly to the endpoint, and I’ve forgotten to send the option “default_access_level” in the fetch. Please, acept my apologies for any inconvenience. Thank you for your support.

1 Like

@Iván_Chao glad you solved your problem and thank you for updating us :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.