Custom field not showing up in "Choose from Library"

I’m trying to add a custom field to a project template. The custom field is in our organization’s field library. However when I go to the “Choose from library” picker and search, the field doesn’t show up in the list. We have many custom fields with similar names so perhaps the “Choose from library” picker only shows the first 30 matches? Unfortunately the custom field that I need isn’t in the 30 fields shown. With a project, I get around this by adding the field via the Asana API. However there doesn’t seem to be a similar API for project templates. How do I add a custom field to a project template if there are more than 30 similarly named fields and mine doesn’t show up in the list of 30 returned in the “Choose from library” search results?

Steps to reproduce:

Create more than 30 custom fields with the words “foo” and “bar”. Search for “foo bar” in the “Choose from library” custom field picker. Try to find the 31st field ← you can’t

Browser version:

Firefox 102.9.0esr

Upload screenshots below:

In case it helps, I created a tool to list custom fields.

1 Like

You can use @Bastien_Siebman’s very useful tool to find in which project your custom field is already. Once you find it in that project, you can edit it by adding an emoji at the beginning of it’s name, like this: :muscle: Estimated Effort

Then go back to the project template where you want to add your custom field and search for :muscle: instead of Estimated Effort. It should logically show up first :wink:

You can then edit the field again to remove the emoji if it bothers others who may be using that custom field elsewhere too.

Since this is expected behaviour and not considered a bug, I will move this post to the tips & tricks section.

1 Like

I don’t own the field so I’m not allowed to edit it. Since I’m still blocked here, is this a bug?

I know the gid of the field if that helps but there’s still no way to select it in the UI.

Can you reach out to the author so they can add it to the library?

…and if it is already in the library, then ask them to edit the field name for you so you can find it easily to add it to your template.

Or simply ask them to unlock the setting ‘Only you can edit this field’s settings’ so you can do it yourself.