completed_by field is missing when getting task data

When getting a task, I do not see the completed_by field. Here is the top part of the json I am receiving:

“gid”: “1199877159975445”,
“assignee”: {
“gid”: “142141169480256”,
“name”: “Regan Carriere”,
“resource_type”: “user”
“assignee_status”: “inbox”,
“completed”: true,
“completed_at”: “2021-02-23T18:21:00.247Z”,
“created_at”: “2021-02-02T20:04:18.585Z”,
“custom_fields”: ,

According to the documentation, I should see “completed_by” right after “completed_at”.

Hi @Patrick_McGrath and welcome to the forum!

That field is not listed in the docs as an opt in field, but maybe it is anyway. Try including a parameter of ?opt_fields=completed_by and see if you get it then. (If so, you’ll likely need to add other fields that you want as well.)


Thanks, Phil! That seems to work. The documentation shows that it should return the name as well, but I just see the gid and resource type. Here’s what the documentation shows:

 "completed_by": {
      "gid": "12345",
      "resource_type": "user",
      "name": "Greg Sanchez"

but I am just seeing this:
  "data" : {
    "gid" : "1199877159975445",
    "completed_at" : "2021-02-23T18:21:00.247Z",
    "completed_by" : {
      "gid" : "142141169480256",
      "resource_type" : "user"
    "name" : "01.25.2021 | The Farm at Hickory Hollow Venue Promo | Custom Video | Orlando"

Do you think I can get the name without making another call?

@Phil_Seeman, never mind, I figured it out.


Thanks for your help!