Bug in sort by Due Date

It seems that if you attempt to sort by Due Date it doesn’t actually sort, it does a group by, which is different as group by adds headers for Past Due, Due this week, etc. How can I just sort by Due Date, as the drop down menu for due date shows, and not group by?

Are you in My Tasks? Did you disable the sort within sections?

1 Like

I am in My Tasks. Sort is disabled for Due Date. If I enable Due Date sort, it instead does a Group By.

I’ve attached a screen shot of what I’m using to attempt to sort but instead it is doing a group by


Did you try:

  1. Group by: Custom sections, then
  2. Sort: Due date?

I think that’s what you’re looking for.


1 Like

At least for me, there is no due date under the sort option next to group by. And if you try and sort by due date by clicking on the due date header, it does not sort it, it did a group by.

1 Like

For me, once you first choose Custom sections, then the Due date option appears in Sort:

If that’s not the case for you, I’d recommend emailing support@asana.com.

1 Like

Ah! I got it. You have to select “Custom Sections”. If you select “None”, then you only get a fraction of the list you have for Sort.

That seems really odd.

Thanks, that mostly did it.

What is odd now, and still seems to be a bug, is that when I do what you suggested, I still have Group Bys of “Due Today”, “Due Next Week”, “Due Later”. There is just nothing in them.

1 Like

You might prefer to remove those sections, then.

You may benefit from reading about My Tasks in How to use Asana, Asana tutorials, onboarding tips, and team use cases | Product guide • Asana Product Guide for more.


This topic was automatically closed after 4 days. New replies are no longer allowed.