Adding Asana to teams is not working

I just created an Asana account, went into teams and added the integration. When I go into a chat or channel and try to add Asana, click on “Connect to Asana”, it opens a popup for https://teams.integrations.asana.plus but its blank and nothing happens.

I tried removing and reinstalling the connector but it continues to do the same thing.

Hello @Nikhil_Kumar1

Sorry you are facing such difficulties.
Sometimes IT teams have certain limitations to what integrations are allowed. Have you checked that there is nothing blocking the integration with Teams to take place?

Rashad

1 Like

Hi @Rashad_Issa,

Thanks for responding, there is no limitation on what integrations are allowed. I checked and I am able to log into other apps/integrations.

Thanks,
Nikhil

Hello @Nikhil_Kumar1

Ok then one last thing to confirm is you are trying to install the integration using the teams desktop app.

Here is the guide on the integrations and the steps needed. It says that Microsoft admins must approve integrations in some cases and desktop app preferred to be used.

If all fails and you are still not getting the integration to work, I would suggest contacting support.

And one last check, if you can try integrating asana with another tool you work with, if that works with no problems, then def contact Microsoft support. If that fails, then I would suggest contacting asana support.

Hope this helps a bit.

1 Like

Hi, I’m having this exact problem. Using the desktop app I’ve tried integrating Asana for a specific team channel and a blank integration screen pops up and it does nothing. It sounds like this needs a platform integration internal fix.

This topic was automatically closed after 9 days. New replies are no longer allowed.