403 Forbidden Error Wordpress

Hello guys,

We have Asana API linked to our Wordpress site. We have several boards and some of them are working just fine but others are returning 403 error.

We have 6 boards and for the first two it works but not for the others. I Have checked all the credentials and they are correct. Only thing that is different are project id numbers but they all match to the right board.

Project id that are working: 1106729261901442 & 1106729261900448.

The ones that are not working: 1110652315829684, 1113313975225388, 1117269152263832, 1125012546209011

Do you please have any idea what can cause this problem?

Hi :wave:
You could not find any difference with the working and not working ones? They are all part of the same team for example ? They have the same visibility options (private versus public)?

Thank you @Bastien_Siebman for your reply.

There are two teams and they are both set to be public for that team. The first one has only one board and that one is working.
The second team has six boards but only one of them is working.

How about the user(s) that created the projects? If it was different people, do you see any correlation there between working and non-working projects? (I know, that shouldn’t really matter if the projects are public, I’m just trying to think of other things to check.)


How is the link done between Wordpress and Asana API? With a personal token for example?


Hi @Phil_Seeman, I have just noticed that the working ones has a different owner so that might be root of the problem.
@Bastien_Siebman Yes, it is linked using personal access token. That’s why I think that the working boards which are created by the guy who created this link using his token works but the others don’t.


I don’t know the personal token well enough, @Phil_Seeman any idea?

I’m afraid I haven’t done much with PATs, either. Even with a PAT, I would think that if the user creating the PAT had access to the project, everything would be OK, but it seems not.

Hey @Matous_Gahut, is the Asana user that generated the PAT a member of every project you need to integrate with WP? Make sure to add the user in case any of the projects are (or become) private to members.

Hi @Jeff_Schneider, yes, the user is in all projects that we want to integrate.

Unfortunately even when he is an owner of the project it’s not working.

Sorry to hear you’re still having this issue, @Matous_Gahut. If the user who generated the PAT has access to the projects in Asana, they should have access to the same projects in the API. I suggest having the user create a new PAT and then have them try the requests again. If the new PAT doesn’t work, could you please email us (devrel@asana.com) the user’s email address as well as the full API request and response that is not working. It’s easiest to troubleshoot if the request is made in curl with a -v flag.

Another way to confirm that the user has access to the project via the API is to try in a browser, which uses cookie auth. To test this, have the user log into Asana and then open a new tab and access the API via a URL (i.e. https://app.asana.com/api/1.0/projects/1110652315829684). If they still get a 403, then I think that the user likely doesn’t have access to those projects in Asana.