Updating a project via API

I’m receiving the below error while updating a project.

responseBody{“errors”:[{“message”:“No matching route for request”,“help”:“For more information on API status codes and how to handle them, read the docs on errors: Errors”}]}


While it’s not the cause of the problem, remove project_gid from your message content; it’s not a valid parameter.

I suspect the problem is that {project_gid} is not resolving to a valid project gid in your URL string. It looks like the variable should be {u_project_id} perhaps?

Thank you, @Phil_Seeman !

I fixed the issue.

Can you let us know how you fixed it, for the benefit of future readers of this thread? Thanks!

In the content, I was using “project_gid”:“${u_project_id}” but in my business rule, I was calling a different ID.

1 Like