Unable to submit information through Asana forms

Important note: To help us resolve your issue as quickly as possible, please ensure to fill out all the sections below. Do not share any private information such as email addresses or phone numbers - This is a public Forum!

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When utilizing Asana forms and hitting the submit button I receive an error message saying that the submission could not be completed.
Steps to reproduce:
Tried across multiple forms across the organization and received the same error message.
Browser version:
Chrome Version 116.0.5845.111 (Official Build) (64-bit)
What version of Asana are you using (Basic/Premium/Business/Enterprise)?
Upload screenshots below:

Hi @Ewen_MacKillop, sorry for the trouble! We had a temporary issue yesterday but it has since been resolved. If you are still unable to submit forms, please let me know!

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.