Prevent creating a new task when pressing enter

In the board view, after creating a new task, typing the task name and then pressing enter, the task is created, but right after that, a new task appears. In the past, it was possible to leave the name field empty and press enter to get rid of this additional task (practically, pressing enter twice would result in creating a single task), but now pressing enter won’t get rid of the additional task (it simply doesn’t do anything if the name field is empty). I’m left with a redundant task that I have to manually delete using the the context menu each time I create a new task.

I usually need to create only a single task at a time, and this behaviour is very unproductive and annoying. This behaviour should either be optional (option to choose whether or not auto-creating an additional task after a new task is created), or pressing enter twice to create a single task should be brought back.

1 Like

Hi @Can_Uzer, welcome to the Asana Community forum! As it stands, it’s currently not possible to prevent that a new task is created when pressing enter. However, when you create a new empty task in board view, the task should be automatically removed from your board. I just tested but I couldn’t reproduce this issue. In order to investigate this further, could you please contact our support team and share this information:

  • Empty task URL
  • Project URL
  • URL of this thread so you don’t need to send all the information again

You can contact our support team following the steps in this thread: How to contact our Support Team ✉

Let me know if I can help you with anything else!

@Emily_Roman if I’m not mistaken, the empty task isn’t automatically deleted if there is a rule on the project that writes something to this new task. For instance, if someone is assigned to a new task added to project.

2 Likes

Good point, @Jerod_Hillard, You are right! :bulb:

@Can_Uzer as Jerod, mentioned if you have a Rule that is automatically adding information to the task (for example, assignee or comment), the task won’t be automatically deleted. You can check if you have any active Rules in your project in the Customize option in the project header.

Thanks for the answers. As you pointed, rules might be the cause of this recent behaviour change, but I can’t 100% confirm this after doing some test. At any rate, it’s not possible for me to remove the rules to switch back to the default behaviour. As a workaround, I press tab+backspace to remove the secondary task, or click on the Add Task button (that removes the task as well). Not ideal, but does the job. However, I would suggest that there should be an option to change this behavior of creating a new task after pressing Enter (or maybe a new shortcut added, let’s say, shift+Enter to create a single task) to improve productivity.