Option to disable dark mode on embedded forms


While I love that dark mode is available for the web and native apps, when we want to embed a form on a website that doesn’t have a dark mode (i.e. a light background color), it looks quite jarring to have a dark box on a white page.

I have my system’s appearance settings set to dark mode, so the form is inheriting that, but it would be nice to optionally force light mode in the form embed via a URL parameter or something.



Hi @anon38177583 , I have also noticed this recently - actually all my forms are in dark mode, either in preview (‘View form’ within the editor) or opening the form from the link, regardless of whether My Settings > Display is in light mode or dark mode.

Hi @Marie , is this a bug or part of an A/B test?

@pforumleader s, have you also noticed this with your forms?

Hi @anon38177583 + @Richard_Sather and thanks for the report. Let me check with our team and get back to you once I have an answer!


I’ve been running into the same problem! Thought I could go in and override dark mode by changing a class, but CORS restrictions won’t allow it. My site doesn’t support dark mode, so this ends up looking really out of place. I’d love to have an option to force light mode in the form config.

Hey @Marie , did you get an answer from the team? I’ve had to roll my team off of Asana because of this issue, but would love to bring them back if we could just enforce styling.

Hi @Forum-team , @Ainhoa_Rico , I am still experiencing this bug :confused:

The form builder/editor appears fine (in light mode). But when you click on the ‘View form’ button in the top right… (or from the Customize menu, under Forms)

…it looks like this:

But when opened in a new browser tab using the form’s link, it’s fine:

I have noticed there is no effect to changing the personal user’s settings to dark mode or not.

Can we please escalate this issue?

It appears to be the same effect when the form is embedded in other websites; perhaps this is similar to what Asana is doing when previewing the form within Asana.

Hi @Richard_Sather, thanks for flagging this and sorry for the trouble!

I have now opened an escalation for our Development Team so they can investigate further and I will circle back here once I hear an update from them!

Thanks for your patience :slight_smile:

Hi @Richard_Sather and All,

Thanks for your patience! After escalating this issue, our Development Team has come back with the following information:

The form view mode page’s color mode (light or dark) is synced with system settings (what the color mode of the device is set at). This means that your system settings is most likely on dark mode, while your Asana display settings are on light mode → there’s a difference between the editor and view modes.

To see the view mode in light mode, you need to change your device’s system settings to light mode as well.

Please let me know if you find this helpful! :slight_smile:

1 Like

Ahaa! That explains it!

@Ainhoa_Rico , thank you reaching out to the dev team and for your quick response!

:bulb: A note to all, after changing my system settings to light mode, I actually had to close and reopen my browser for the effect to take place. Just refreshing the browser wasn’t enough.


This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.