OAuth does not work on .ME domain name.

Hello, I am working on an experimental Asana agile dashboard app in PHP. This issue is strange, “Sign in with Asana” is working fine in all the TLD’s (tested .com, .info, .in and .net) except .ME TLD, this was spotted, when I was deploying an app from development environment accessed at abc.com to abc me

At .ME TLD environment, Asana Connect throws following 400 error " invalid_request: The redirect_uri parameter does not match a valid url for the application."

But same codebase in .COM TLD, works just fine.

Is there any work around to fix this issue?

Any help much appreciated, Thanks.

@Joe_Trollo is this not authorized as a redirect url?

Hi @Liana_Melissa, URLs with domains ending in .me are acceptable as redirect URLs, and work in my tests attempting to reproduce the issue. Can you please confirm that the redirect_uri parameter in the authorization URL you send users to matches a registered redirect URL for your app in the developer console? You’ll need to make sure that both locations are updated and have matching information, i.e., you’ll need to change more than just pieces of your codebase.

1 Like