New membership endpoint not working as expected for PUT requests


You can see below my attempts: a PUT request on a specific membership to change the access. It worked with comment_only but any other option fails…

Any idea?


PS: I still don’t understand why the API says we have to use ADMIN CONTRIBUTOR COMMENTER, these are not the right options…

cc @sasha_f


Hi @Bastien_Siebman , I tried the following command but I get back an error with a very unhelpful message (“Not Found”). What, if anything, am I doing wrong?

Note: I have replaced personal data (GIDs, API tokens) with generic text between <<>>.

curl --request PUT \
     --url<<membership_gid>> \
     --header 'authorization: Bearer <<my_api_token>>' \
     --header 'accept: application/json' \
     --header 'Asana-Enable: new_memberships' \
     --header 'content-type: application/json' \
     --data '{"data": {
  "member": "<<member_gid>>",
  "parent": "<<project_gid>>",
  "resource_type": "membership",
  "resource_subtype": "project_membership",
  "standard_access_level": "commenter" }}'


The memberships endpoint you’re trying to access has been rolled back for now in the form in which you’re trying to use it. See: