Duplicating Projects too many request

Hello!
My organisation is currently utilising the duplicating projects feature and it was working perfectly fine.
However, since yesterday I have come across an issue where it was returning a 429 error message -

“You have made too many requests recently. Please, be chill.”

In the json response, it also had
“retry_after”:60

I encountered this problem during testing when I was trying to fix a bug in my code, which in turn was making many requests to the server.
Essentially what my code does is when there is an issue with the whole process, it would then delete the duplicated project.

E.g. I duplicate project, create task in project, if task fails to be created, delete project.

There was an issue with create task which I managed to fix, however when I got to duplicating the project again, it came back with the too many request error.

I have waited for a minute before trying to duplicating the project, and it still hasn’t cleared the error. I even waited for a full 12 hours and it still hasn’t been cleared.

I have tried changing my personal access token, using different computers, duplicating a different project with smaller amount of tasks, etc. I even tried to just use the terminal and still I get this error message.

If I could get some assistance in this, that would be amazing!

@Ross_Grambo, any ideas here?

You did the right thing by waiting 60 seconds as it dictated. I have no idea why you’d still be getting that error after a number of hours.

1 Like

Not sure why that would happen. Could you DM me the ID of your app/pat? (Don’t send the actual token)

Hey @Tony_Anh_Nguyen,

I had the API team investigate, and they said it’s likely that you’re hitting our concurrent write rate limit (15). This means your PAT cannot have >15 write requests running at a time. I imagine your script is running everything in parallel?

Hello @Ross_Grambo,

I attempted to duplicate today, and strangely enough it is now working.

With the concurrent write rate limit, I don’t believe I was running that many api at the same time, and also the error only came up for duplicating projects and duplicating tasks.

On the day of when the error happened, I was doing the following whilst testing:
In that short minute I essentially:
Duplicate -> Create Task -> Delete Task.
Duplicate -> Create task -> Delete task.
Duplicate -> create task -> Delete Task.
and eventually it just gave me an error in the duplicate project, and thus stopping me from duplicating ANY projects and tasks for a couple of days.

However, they were not running in parallel. Once duplication finishes, it then creates the task. If task fails, it then deletes the project.

Everything else works perfectly fine; Create task, Delete task, etc.
But it just wasn’t letting me duplicate.

Anyways, I don’t know how it got fixed, but it did.

I do have other scripts which are using the same PAT to create tasks, which are currently active. It might be possible that other people were using it, and thus it somehow hit the 15 concurrent limit.
But even so, I didn’t think it would stop me from specifically duplicating for a whole 2 days or so.

What I might do as a safe measure is possibly having multiple PATs for different scripts. That way, I can leave a paper trail as to when every script last ran by looking at the PATs.

Hmmm. Well I’m happy that it’s working now!

I’m sure separate PAT’s will help. If this issue still happens, I can dig deeper into our logs to find the exact cause/requests causing the issue.

I’ll leave a note for the API team that it seemed to happen on the duplicate endpoint and not other endpoints in case this happens to you or others in the future.

1 Like