Decimal place isn't mapping from form to custom field

Briefly describe (1-2 sentences) the Bug you’re experiencing:
I have a number custom field (percentage with two decimal places). I connected the field to a form question. When I enter 11.11% and submit the form, I get 1111.00% in the custom field I have it connected to.

Steps to reproduce:

Browser version:

Upload screenshots below:

1 Like

Hi @Cammille_Powell, welcome to the Asana Community Forum :wave:

Thanks for flagging this! Have you got the percentage field set to 2 decimal points, as seen in the screenshot below?

Screenshot 2022-01-11 at 09.08.40

You can check this by editing the field.

Looking forward to hearing back from you :slight_smile:

1 Like

@Cammille_Powell and while you try what @Rebecca_McGrath shared with you, please consider this:

either have the field as number and then enter percentage in the form
or have the field as percentage and when you enter the figure in the form, do not add the % symbol.

I believe this could be like excel where if you enter a % in and cell already formatted as parentage, the figure will be 'double %‘d’ if that makes sense.

1 Like

Hi @Rebecca_McGrath and @Rashad_Issa thank you for your tips. I probably should have included this in my original post, but I have already added the decimal places. Since the field is already a percentage field on the form (mapped to a percentage custom field, it won’t accept the % character in the response). I did try the suggestion of changing the field to a general number field and adding the % character, and when I did so I got the message “this field can only contain numbers”.

I’m thinking my only option to make the mapping work now is to try using a text custom field to have the form response map to instead. In doing so however, it still doesn’t fix the fact that this is a bug. If I input a decimal place in my number/percentage response field with no issue, it should appear the same way in the custom field it’s mapped to!

Happy to try other suggestions, and I appreciate your responses!

1 Like

Hi @Cammille_Powell thanks for the further clarification. Sorry to hear that you already tried different approaches.
I just made a test and I can replicate the issue as well. You are right, it is a bug.
If you have not done so already, please report it on here: Asana Support - Help Center • Asana

Okay, thank you!

Thanks for following up here @Cammille_Powell and thanks for testing on your end too @Rashad_Issa!

Our Product team has confirmed that this is actually expected behaviour at the moment, although they understand it’s not ideal. They’re currently working towards a solution here so I’ll keep you updated and let you know if any changes are made :slight_smile:

Hey @Rebecca_McGrath thanks for checking and confirming!

It is disappointing to know they confirmed it is expected behaviour. This doesn’t make sense.
I really hope someone would look into this for an urgent fix please!