Create subtask is creating blank object

I am calling /tasks//subtasks with the following data

{"data": {
"approval_status":"pending",
"assignee":"<AssigneeID>",
"completed":false,
"completed_by":null,
"custom_fields":null,
"due_at":null,
"due_on":null,
"external":null,
"followers":null,
"html_notes":null,
"liked":false,
"name":"Examine original report",
"notes":"",
"parent":"<parentID>",
"projects":null,
"resource_subtype":"default_task",
"start_on":null,
"tags":null,
"workspace":"<workspaceID>"
}

It is successfully creating a subtask but it is empty of any of the data I am passing
image

Hi @asher.brooks,

A few potential issues I can see:

  1. The account you’re attempting to write to - is it at the Business or Enterprise level? approval_status is only available at those levels, otherwise the task creation won’t be successful.
  2. Don’t specify parent. You’re providing the parent’s gid in the URL string itself (that’s been left out in your example but I assume that happened here in the forum when you tried to paste something in there).
  3. completed_by is not writeable; leave that out.
  4. In fact, just omit any field that’s null; there’s no value in sending those.

Thanks for replay Phil,

So with a simplified test I get the same result
image

image

The account definetly has the right permissions becuase the post is successful.

Hmm, I don’t know why it’s not working properly.

Have you tried creating a top-level task (not a subtask) and does it do the same thing?

Have you tried creating it in Postman (or equivalent tool) - if not, I would recommend doing that, to see if it’s somehow a function of your specific client environment (though I can’t imagine what that would be that would create the task but not populate the name).