Can't get all webhooks created in workspace

Hi,

I have created Webhooks in my workspace. While I am trying get all webhooks created in my workspace using > GET /webhooks?workspace=[workspace_id], it returns an empty list. Whereas I am able to get specific webhook using > GET /webhooks/[webhook_id]. So why it returns an empty list while I am trying to get all webhooks for my workspace? Can you help me, please?

FYI: I am using same token to get the webhook which I have used to create it.

Thanks!

Hi @Niral_Shah and welcome to the forum!

It seems this is an issue others have had as well; see this other thread:

Per that thread, the Asana API team has not been able to reproduce the issue.

@Joe_Trollo any thoughts on this?

Hi @Phil_Seeman,

I read that thread. As mentioned in that thread, webhooks are only visible to the user and app/PAT that created them. I am using same PAT that created the webhooks but still it is returning an empty list. So any thoughts on this?

Thanks!

i’m having this same issue. in my case i’m creating the webhook with the api, and i know it’s firing.

here’s what i posted to create the webhook.

“data”: {
“filters”: [
{
“resource_type”: “task”,
“resource_subtype”: “default_task”,
“action”: “changed”,
“fields”: [
“custom_fields”,
“due_on”,
“assignee”
]
}
],
“resource”: “’[boardnumberhere]’”,
“target”: “https://mydomainandpath/asana_webhook.php
}
}

but i’m getting 6 webhooks for each change i make to one column. each notification is the same and has over 67 events dating back to what seems to be exactly 24 hours ago.

so… i wanted to get a list of webhooks to see if i have more than 1 somehow.

so i tried GET /webhooks?limit=10&workspace=115546325724923 (*on api explorer, but presumably using the same token. and btw, get /webhooks requires workspace entered as an extra parameter even if i select ‘skyrun.com’ on the dropdown (which is the only choice).

i also tried GET /webhooks?limit=10&workspace=115546325724923&resource=1190420945734503 (adding resource=) with the same project number and workspace id used to create the webhook.

in both cases i get this in return

{
“data”: ,
“next_page”: null
}