API explorer webhooks endpoint missing workspace parameter

Summary:

When the Asana API explorer is used to GET /webhooks, the resulting API request is missing the mandatory workspace parameter. This is unexpected considering the “Workspace” drop-down field shows the workspace to be used for the request.

Steps to reproduce:

  • Observe how /users endpoint behaves:
    1. Go to Asana API explorer
    2. Select “Users” in the top drop-down field
    3. Select “GET /users” in the second drop-down field
    4. Confirm that the workspace parameter is included in the API request according to the selection in the “Workspace” drop-down field
  • Observe how /webhooks endpoint behaves differently:
    1. Go to Asana API explorer
    2. Select “Webhooks” in the top drop-down field
    3. Select “GET /webhooks” in the second drop-down field
    4. See that the workspace parameter is missing in the API request, regardless of the selection in the “Workspace” drop-down field

Screenshots:

Hi @mxxk,

(I moved this to the Developers & API section where the Asana API team monitors for develop issues. )

Calling @Ross_Grambo:slight_smile:

This looks similar to this other Explorer bug:

Get /portfolios returning "You should specify one of workspace" error

1 Like